Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
After recently replacing a dead battery, my odometer and gear indicator lamps stopped working. The other lights on the dashboard still light, just not the odo. & gear lamps. There does not appear to be a separate fuse for these, so I fear something else is wrong. Any clues or advise would be appreciated.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
115 Posts
There are multiple bulbs that back light the instrument panel. You probably need to replace 1 or more. I haven't had to replace any yet so I haven't seen the backside of the cluster yet. I would suggest that if you are going to pull the cluster and replace the bulbs that you replace them with LEDs that will live a lot longer than regular bulbs.

I'm sure someone will come along with step by step instructions on how to replace them, what bulb number you will need and how many.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
497 Posts
I just re-did my cluster with LEDs over the weekend. The gear-selection indicators and odometer are not lit using traditional incandescent lighting. They use their own displays with integrated lights. If they are both out, I would think it is probably a fuse issue. If it's not a fuse, they must share another common component, separate from the remainder of the cluster.
 

·
Registered
2002 chevy trailblazer_ltz
Joined
·
7 Posts
what if the lights are going off and on intermintently? Also now the side seat controls on the door are also not working?
 
1 - 4 of 4 Posts
Top