Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2007 gmc envoy_denali
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hello There, Odd issue here and completely lost. I have an 07 Envoy Denali with 200k on it. In the past year I've had a number of issues with the brakes. The biggest issue that seems nobody can resolve is the fact that I seem to get air in my lines after approx 2 to 2 1/2 months after a full ABS bleed. I have had the dealer do the last one because my mechanic was just at his wits end. THere appears to be no visible leaks anywhere. The Master Cylinder has been replaced multiple times. No fluid or leaks in the booster. Replaced rear calipers and one hose that was collapsed in the rear. If anyone has any ideas I'd sure love to hear them because everything at this point doesn't seem to stick to the wall. I will not give up on this Envoy as it has been the best car I have ever owned. 200K runs strong and looks fantastic to me. Hopefully someone has an idea here. Thank you.

Also forgot to add that while driving I can push pedal once to the floor release and apply again and there is pressure in order to brake normally.
 

·
Registered
2007 gmc envoy_denali
Joined
·
2 Posts
Discussion Starter #3
Well as of the initial post I took it to a GMC dealer to get it troubleshot. They replaced the master cylinder with a GM OEM part which almost lasted a year. Brakes were awesome for almost one year. My Envoy sat for about a week and the brakes took a turn to the same behavior. Pedal all the way to the floor and another pump will firm it up. I am going to go back to the dealer and let them replace the MC under warranty for the part. I’m at a complete loss here. ABS works with no issues or codes. No fluid loss. No collapsed lines. Fluid full in MC. Gremlins!
 
1 - 3 of 3 Posts
Top