Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 10 of 10 Posts

·
Registered
2004 gmc envoy_sle_xl
Joined
·
91 Posts
Discussion Starter · #1 ·
I just replaced my thermostat and temp sensor. Stock replacement thermostat, and my gauge is reading over 210. Before I replaced it I would never get close to that. Just wondering if this is normal operating temperature.

Car Steering part Speedometer Plant Tachometer
 

·
Premium Member
'05 Chevy TB EXT
Joined
·
4,051 Posts
Where does that temp gauge sit when the ignition is OFF?

I ask that because the stepper motor, if it starts at higer than the bottom of the gauge, it is either out of adjustment or it's going bad.

They ARE adjustable --- really!
 

·
Registered
2004 Trailblazer LS 4.20 L
Joined
·
115 Posts
may have to bleed some air out of the system. should be a little bleeder valve somewhere by the thermostat. crack that open as it gets to temp. you want a pretty solid stream without any interruptions. sometimes you'll have to do that a few times. did you flush the system?
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
23 Posts
may have to bleed some air out of the system. should be a little bleeder valve somewhere by the thermostat. crack that open as it gets to temp. you want a pretty solid stream without any interruptions. sometimes you'll have to do that a few times. did you flush the system?
Have you ever seen this bleeder valve? Maybe I am blind but I did not see one when I changed the 'stat and really do not think there is one. If there is, please show me where it located. Thanks - - -
 
1 - 10 of 10 Posts
Top