Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello,
Problem i am having with my 07tb. Started with a no start at times not very often. No crank,no security light flashing. Then would fire up after 3 or 4 trys. Also had a stability light at times and SRS light at times. Had at dealer and they said they repaired SRS wiring (bad connection) Ok ill believe that.
Said the replaced the steering angle sensor due to bad readings and it had set a code. OK Then they said to bring back Tb so they could replace ignition switch due to high failure rate at no cost. Well took it back and they did the work. Now i am having a no start at times ( no Crank) and the fuel gauge suddenly started acting up and will get a stall out at times Took it back and now they say they cant duplicate problem and no codes present.
But it will do it every other day or so. Truck only has 14,400 miles Plus they hit the rear bumper cover and damage it :cry: Thanks for any help
zinroe
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Your dealer is a goof. Make them fix the bumper, then take it to another one to fix your problems. You might have another bad ignition switch or a loose connector. Very difficult to guess without a tech tool hooked up to the vehicle when the problem happens, if it's intermittent.
 

·
Registered
2004 gmc envoy_sle
Joined
·
399 Posts
Yea, they fubard something with the ignition switch. Also, when I had my truck in at the dealer, one of the car jockey's backed into it and scratched the bumper cap. My service manager called me and told me about it and bring it back and they'd fix it. If he hadn't pointed it out closely, I would never have noticed it, but they still fixed it. Make sure they take care of it.:nono:
 
1 - 3 of 3 Posts
Top