Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2007 chevy trailblazer_ls
Joined
·
1 Posts
Discussion Starter #1
Hello, I have seen other threads about this, but needed to add a few other concerns.
I have a 2007 Trailblazer and it has been driving fine. just had tranny lines replaced at the dealer and no other issues.
over the past couple of days, the traction control light has come on once, but went off after restarting the vehicle. I noticed no problems.
But today, I started the vehicle and drove without issues. I stopped at a farm supply store and shut off the truck to load my purchase. when I went to start, the truck went dead and I could not get the key out. when I tried to start again....nothing. The mechanic at the store hooked up the jumper pack and the truck started slowly, but we noticed that the battery was DEAD. I drove home, shut off the truck and got the same result... no power.
there were no signs, like the battery was dying or alternator was bad. The truck drove fine and suddenly, it was dead.
anyone have any issues similar to this? any information will help.

Thanks.
 

·
Registered
2005 gmc envoy_sle
Joined
·
39 Posts
Battery may have shorted out. Has no warning and will do this. Your keys will come out if you charge or jump it a little. Car needs power to remove the keys. This happened to me. Take battery out and go get it load tested.
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
1 Posts
Discussion Starter #3
:thx
to DaCoach for your input. it was my battery and once I put the jumper cables on, the truck lit up and keys came out.
I replaced the battery and have not had any problems since.

thank you.
 
1 - 3 of 3 Posts
Top