Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
so i've treid looking for threads concerning my problem but I can't seem to find them so I thought I may as well post. I've got a 02 trail blazer with automatic heat controls but low and behold it gets cold and I find that my passenger side vents blow cold air (drivers side is fine) or at least not hot air and to compound the matter the rear vents blow cold too anyone have any ideas on how to fix this problem? checked the hvac fuses under the rear seat and none are blown.


any help would be very appreciated
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Someone posted a reset procedure for the auto HVAC. It uses the HVAC controls, holding them for a few seconds and the control unit resets.
Not sure if this is the problem, but couldn't hurt to try.
Problem, I can't find the thread (too many hits), bit I've read it on here. So......it is here.
 

·
Registered
2002 olds bravada
Joined
·
2,369 Posts
there are two reset procedures: one is pulling out all the fuses for the HVAC system under the seat, the other is holding the Mode, rear defrost, and defrost buttons at the same time.

if you are going to pull out the fuses, make sure your ingition is in the on position, but not actually started, and pull them out for about 10 seconds. put them back in and leave them in for about 30 seconds before doing anything...see if that works
 
1 - 5 of 5 Posts
Top