Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello everyone,
I am new to this forum. I have a 2002 Trailblazer and I enjoy driving it. But today I encountered a problem with the dashboard. There is no activity. No lights. The fuel battery, temperature gauages are not working. The gear selector and miles is not on. I cannot see the miles driven. The RPM and speedometer rests on zero while I am driving it. Basically looks like the vehicle is turned off but I am able to drive it. Any help is greatly appredicated.:thx
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
1,077 Posts
Your insturment cluster probably has failed which is common in this trucks. I would also check the fuse box incase a fuse has blown.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Your insturment cluster probably has failed which is common in this trucks. I would also check the fuse box incase a fuse has blown.
Thanks for the advice Parrothead. I was getting ready to check the manual to see what fuse # is for the instrumental cluster, I told myself why not try starting it. What do you know, everything is working normal again. I then drove it to work this morning and it is working like nothing every happen. If this does happen again, would you now what fuse # it is? Thanks again.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Probably your ignition switch, but you have some unusual symptoms
My ignition starts fine. I am able to play radio, open and close windows. Another thing that happen when the instrument cluster went out is that my head lights wen out also. It is very unusual.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2,667 Posts
My ignition starts fine. I am able to play radio, open and close windows. Another thing that happen when the instrument cluster went out is that my head lights wen out also. It is very unusual.
Don't rule out your ignition switch. We have seen it cause some weird things. Anything from the vehicle not starting to all sorts of other electrical problems.

Though I agree it sounds like it could be a bad ground or the instrument cluster going bad.

Somebody a while back had electrical problems and it was his battery terminals were dirty and a little loose (IIRC).
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Don't rule out your ignition switch. We have seen it cause some weird things. Anything from the vehicle not starting to all sorts of other electrical problems.

Though I agree it sounds like it could be a bad ground or the instrument cluster going bad.

Somebody a while back had electrical problems and it was his battery terminals were dirty and a little loose (IIRC).
I'll check the battery terminals. What are IIRC?
 
1 - 11 of 11 Posts
Top