Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i have a no crank issue.
to start the battery is good , the starter is good and i have to supply power to the purple signal wire going to the starter or jump the wires 86 to 30 on the starter relay socket in order to start the truck. after reading the schematic on the starting system, when you attempt to start the vehicle, it should receive a ground signal from the pcm(starter enable relay control). i am not getting a signal to that socket on the starter relay. also , the crank fuse should activate as well when attempting to start the vehicle. i am getting nothing there. I am also not getting anything out of the yellow wire on the ignition switch which is going to the crank fuse, which is a good fuse.
Any help will greatly be appreciated because i also have a 06 monte carlo with the same issue and i had to start it with a manual switch
thanks all
 

·
Registered
2002 Chevy Trailblazer LTZ 4X4
Joined
·
4 Posts
I'm having the same issue exactly with my '02' Trailblazer LTZ. a relay fried on my way home from work Friday night driving 30MPH and left me stranded in the center turn lane until I pushed it off the road. It was the Ignition/AC/Fuel pressure/PCM relay. I replaced it with no avail. After my second attempt to start my truck, the battery was dead already. Today I replaced the Ignition switch and checked all my fuses under the hood and under the rear seat on drivers side. Tried to jump it to start it and still 'No crank No start' I hope we can both figure this out!! Seems to be a normal issue with these vehicles. I love my Blazer tho!! Best of luck!!
 
1 - 2 of 2 Posts
Top