Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 9 of 9 Posts

·
Registered
2006 chevy trailblazer_ss_3ss
Joined
·
9 Posts
Discussion Starter #1
Just picked up an 06 awd ss from the family of a friend that passed away.
I know he programmed it with a diablo tuner (which i still have) and he deleted the cats. THe truck is throwing a p0171 code for a lean condition. We changed the corresponding o2 sensor and the light came back on within a mile. The cats have been programmed out of the computer and were cut out of the truck. My questiion is, does anyone know if i put some hi flo cats in it will this light go off? We hav checked everything else like the intake and the maf. Any suggestions would be greatly appreciated. thanks
 

·
Registered
2006 chevy trailblazer_ss_3ss
Joined
·
9 Posts
Discussion Starter #3
I cleaned the maf the other day and. Made sure all was tight. There is an. After market specter cold air intake. I will clean the filter and see what happens.
.thanks
 

·
Registered
2006 chevy trailblazer_ss_3ss
Joined
·
9 Posts
Discussion Starter #4
SO i borrowed a Maf from a friends truck and the light stayed off for much longer. About 30 minutes, 12 or so miles, then came back on about a mile after a restart. I put mine back on and cleared the code, didnt even get a mile before it came back on. Any suggestions?
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
224 Posts
no exhaust leaks when cats cut out, before o2 sensor ? could try fuel injector cleaner, new fuel filter. check all connections before maf sensor make sure there tight. also did you check code after replacing maf see if any other codes pop up ?
 

·
Registered
2006 chevy trailblazer_ss_3ss
Joined
·
9 Posts
Discussion Starter #6
No leaks that I can see or hear. Everything seems tight. I will try the fuel filter. Thanks
 

·
Registered
2006 chevy trailblazer_ss_3ss
Joined
·
9 Posts
Discussion Starter #7
Threw a new maf in. Same issue. Going to have it tuned in the next few weeks and just deal with the light until then
 

·
Registered
2002 gmc envoy_slt
Joined
·
3,203 Posts
If the down-pipe in the intake has been replaced, you need the PCM retuned to compensate for the add'l air being sucked into the engine. The SS (and 5.3 to a lesser extent) run lean when you add a higher flowing CAI. The better/higher the flowing the intake, the more lean she'll run. I recall one of the tuners pointing this out way-way back and went so far as to state they ran dangerously lean. If you have the OEM intake pipes, toss them on and the lean condition will most likely go away.

Update: Just did some searching, it was GTPprix at Vector that found the issues when replacing the down pipe, the engine 'runs fat down low and dangerously lean at the top' in his words. (Low/Top refers to rpms, I'm betting the code comes on right after you try accelerating the first time or two).
 

·
Registered
2006 chevy trailblazer_ss_3ss
Joined
·
9 Posts
Discussion Starter #9
I don't have any of the stock parts. They are probably sitting in the guys apartment along with the extra set of keys, but his family is still too distraught to go there to clean it out. I already spoke to a local tuner that does trucks and did my impala. Thanks for the info everyone.
 
1 - 9 of 9 Posts
Top