Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 11 of 11 Posts

·
Registered
2003 chevy trailblazer_lt
Joined
·
1,289 Posts
Discussion Starter · #1 ·
Well this morning I noticed my air no longer works on air selector 1. I've been searching forms to find a solution and nothing really fit anyone have anything that I can try. I had problems in the past with the dash vents not working and it turned out to be the actuator fixed that. So if anyone knows anything or has any ideas its greatly appreciated. :thx
 

·
Registered
Joined
·
1,373 Posts
sounds like a defective blower motor resistor pack:undecided
 

·
Registered
2003 chevy trailblazer_lt
Joined
·
1,289 Posts
Discussion Starter · #3 ·
Do you know of anyway on how to test it, is there a how i couldnt find one.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
694 Posts
sounds like a defective blower motor resistor pack:undecided
:iagree: This is a HIGHLY common problem on late model GM's. It has happened on my 04 Colorado, my wifes 07 Malibu and starting to get the symptoms in my 04 TB. Just more proof for GM that lowest bid doesnt always work when outsourcing parts manufacturing! :hissy:
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
10 Posts
Well this morning I noticed my air no longer works on air selector 1. I've been searching forms to find a solution and nothing really fit anyone have anything that I can try. I had problems in the past with the dash vents not working and it turned out to be the actuator fixed that. So if anyone knows anything or has any ideas its greatly appreciated. :thx
I am having that same problem (no air through the vents,just defrost and floor) how did you fix the actuator i dont even know where it is. thanks
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
10 Posts
just replaced the actuator, now it just blows through the vents and not to the floor or defrost. now what??
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
You might have installed it rotated from where it wanted to start out. Were you careful to match the position of the replacement from the one you removed?

Or it might need to recalibrate itself, which I've posted the procedure in almost every other thread about actuator replacement and HVAC problems.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
10 Posts
I was careful about having the new one in the same position and i tried to reset it also. I can see both actuators moving when switching modes I only get defrost and vents now, no floor Thanks for the advice
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
All I can think of is that it's still in an incorrect start position. Got any trailvoy-owning friends you can look at their actuators in? Otherwise it's trial and error.
 
1 - 11 of 11 Posts
Top