Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

21 - 40 of 53 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
24 Posts
Even though it was freezing out, I was shocked when I read this so I had to check to make sure this wasnt happening with my 02 TB but I had nothing to worry about because it all seemed to be working right.
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
39 Posts
I was running to my TB in my shorts and a shirt as soon as I read bout this. Mine is working fine, I checked everything if its really locked. Glad is only -9 outside.
 

·
Registered
2008 chevy trailblazer_ls
Joined
·
32 Posts
Thank you to everyone who posted the how-to's and pictures regarding this. I actually had several christmas gifts stolen from my TB this past weekend while visiting family.

after reading here and testing the different scenarios, the alarm would not go off if the lift gate glass was opened real slowly. I also came to realize that after the lift gate glass button was pressed in, the entire rear hatch was able to be opened without the alarm being activated if opened slowly.
 

·
Registered
2008 chevy trailblazer_ls
Joined
·
1,587 Posts
Just checked mine. Mine is locked. When I lock my truck it I always click it two times until the horn beeps. It is my understanding that when you double click it to lock( and the horn sounds) the second time disables the starter to some degree on the newer models. I am sure "the bad guys" know away around that.:undecided Glad I saw this so I could check it out. Tomorrow I will try some farther testing.
Thanks for posting.:tiphat

.
 

·
Registered
2002 gmc envoy_slt
Joined
·
6 Posts
Just wondering, my liftgate doesn't lock, hasn't for about a month. I was told it is the liftgate actuator. Just wondering if I have the right part # 25664288? On some website it says it's for the LH side, but on gmpartsdirect it says it is for the liftgate.
Any help would be greatly appreciated!
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
74 Posts
yup i had the same issue with mine this indipendent mechanic i go to fixed it for like 100 dollars he had to take the whole thing apart
 

·
Registered
2007 saab 9_7x
Joined
·
14 Posts
My Saab is UNSECURE!!! I brought it to the dealer and they're ordering a replacement part so it can be fixed asap. For now I will be leaving my car EMPTY!
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
20 Posts
I just had this problem in my 07 TB. I adjusted the link as described but it still was flaky. Sometimes it would not lock fully, or sometimes, i would push in the glass release and it would pop the lock for the main hatch!

Anyway, noone else has posted this yet so here is what I did - lube all linkages. I was at my wits end with this problem and thought the levers were a bit hard to move, so i took out the wd40 and lubed all the joints.

It now works perfectly.

Thanks to those who posted pics, service bulletins and other tips!
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
241 Posts
I just had this problem in my 07 TB. I adjusted the link as described but it still was flaky. Sometimes it would not lock fully, or sometimes, i would push in the glass release and it would pop the lock for the main hatch!

Anyway, noone else has posted this yet so here is what I did - lube all linkages. I was at my wits end with this problem and thought the levers were a bit hard to move, so i took out the wd40 and lubed all the joints.

It now works perfectly.

Thanks to those who posted pics, service bulletins and other tips!
did you flip the washer like you're supposed to to prevent the glass release from unlocking the liftgate?
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
3 Posts
I checked mine recently, and of course neither the liftgate or window locked with the tranmitter. I took the panel off to do the fix and found while fiddling around with the linkage (just moving it around manualy from the inside.) The lock now works with the transmitter.
 

·
Registered
2003 chevy trailblazer_ltz
Joined
·
20 Posts
lock is not working

I adjusted the glass latch rod and the button contact the plate to open and close the glass but my lock is not working at all. I can't seem to figure out what needs replaced there? I sprayed wd 40 on everything in there so its all lubricated but the lock is not clicking or anything when i use the lock fob on my key :hissy:ring.
 

·
Registered
2003 chevy trailblazer_lt
Joined
·
47 Posts
I'm in the same boat. My kids told me the hatch doesn't latch.
I checked it and BOTH the glass/hatch won't lock! I cleaned &
sprayed down the linkage and nothing, still won't lock:duh:
 

·
Registered
2003 chevy trailblazer_ltz
Joined
·
20 Posts
I had to replace the actuator in the hatch , got it at the salvage yard for $50.00 i think it was. Works fine now :)
 

·
Registered
2003 chevy trailblazer_lt
Joined
·
47 Posts
Good to know!
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
2 Posts
Easy Fix

I just found this thread. I was having the same issue. I flipped the washer and the lock works correctly now.
 

·
Registered
2007 chevy trailblazer_ls
Joined
·
2 Posts
Turtleman

Good Pics and good discussion on adjusting the linkage rod. I opened my panel up and found that by cleaning and lubing the whole thing it freed up and the lock mechanism traveled properly.
The ass end of a car or truck is a dirty place. Dust gets into these moving parts and needs to be cleaned and then lubed. WD-40 and some compressed air do wonders for cleaning then some liquid graphite spray for lubrication. The graphite makes a good lube in this case as it does not attract dirt/dust like oil or grease would.
Amazing how prevelent this problem is. Hope we get this fixed on our Blazers before the goons out there figure it out. I bet many of them already have.
 

·
Registered
2007 chevy trailblazer_lt
Joined
·
15 Posts
Just found out about this, checked my '07, and my lock works fine.

However, my trailblazer was broken into last year. They just smashed the rear window. I had locked the car with the fob, but alarm never sounded. Not sure if the glass was locked as well, but thieves didn't care and just broke out the entire window.

So, I installed a Viper Alarm that has very sensitive vibration sensor, in addition to normal alarm features. I am very confident the alarm system and locks work well now.

BTW: got the alarm and installation at Best Buy.
 
21 - 40 of 53 Posts
Top