Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 10 of 10 Posts

·
Registered
2006 gmc envoy_slt_xl
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello everyone and thanks for such a helpful site. I have a 2006 Envoy with 75k miles on her. I just replaced my A/C coils and yesterday during the 93°heat of florida I started it up and let it idle with the A/C on for about 5 minutes and then all of a sudden steam hissed out from the bottom left side of the engine it had a smell like coolant yet the steam was white. About a week ago I added some coolant to the overflow. Could I have put in too much coolant? Or do I have hose leak? Or is this from the newly installed A/C coils? Thanks in advance for any help.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1,708 Posts
Hello everyone and thanks for such a helpful site. I have a 2006 Envoy with 75k miles on her. I just replaced my A/C coils and yesterday during the 93°heat of florida I started it up and let it idle with the A/C on for about 5 minutes and then all of a sudden steam hissed out from the bottom left side of the engine it had a smell like coolant yet the steam was white. About a week ago I added some coolant to the overflow. Could I have put in too much coolant? Or do I have hose leak? Or is this from the newly installed A/C coils? Thanks in advance for any help.
Welcome. If the AC got warm after that and the stuff comming out of the left side was not water then you developed a 134A leak. It is not always good to let it idle for a long time when hot. You can develop high pressure because there is a small amount of air going over the condenser coils. If you do not know how to work on AC systems you might want to take it to your favorate mechanic.
 

·
Registered
2004 gmc envoy_slt
Joined
·
8 Posts
Hello everyone and thanks for such a helpful site. I have a 2006 Envoy with 75k miles on her. I just replaced my A/C coils and yesterday during the 93°heat of florida I started it up and let it idle with the A/C on for about 5 minutes and then all of a sudden steam hissed out from the bottom left side of the engine it had a smell like coolant yet the steam was white. About a week ago I added some coolant to the overflow. Could I have put in too much coolant? Or do I have hose leak? Or is this from the newly installed A/C coils? Thanks in advance for any help.
You may have the same problem I have. Check out this thread and see if it is. http://forums.trailvoy.com/showthread.php?t=59242

I also live in Florida and know what the heat can do to it.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top