Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
2004 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone! This is my first post here. I just got a 2004 Trailblazer LS with 126K miles a couple of days ago. It ran fine but I was bored so I started doing some of the stuff listed on this site. So far I've cleaned the throttle body (unhooked the battery for about 2 hours), put a new air filter in, changed the thermostat, and cleaned the CPAS. But I've noticed a small hesitation when you put the truck in park afters its warmed up and just barely and I mean barely press the gas. Sometimes the RPMs dip about 100 or so RPM then shoot back up. I noticed that the CPAS is leaking a pretty decent amount of oil, enough to have the plug full of oil about 10 miles after cleaning it and the wires going to the plug have oil on them and there's an oil stain below the CPAS. When I pulled it to clean it there was hardly any build up on the screens, but I was wondering if its leaking that much is it possible that it has started to fail and is causing the stutter, or is there anything else I should check? This site has been very helpful so far so I hope you guys can give me some advice! Thanks!
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Good thing to spot, and yes, I'd change it.

Also do plugs and upstream O2 sensor, plus all the fluids unless you know they were done at 100K except the transfer case which is 50K.
 

·
Registered
2003 gmc envoy_sle
Joined
·
2 Posts
Cpas

Check GMpartsdirect.com for this part. If you can wait to have it shipped, it's alot cheaper.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
2 Posts
Discussion Starter · #4 ·
Alright. I'll change the CPAS along with the 02 sensor and plugs and post the results for anyone that's interested. Thanks for your help!
 
1 - 4 of 4 Posts
Top