Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Thank you for letting me join this forum. My wife and I are both in college and broke as can be. Our previous car we owned for a few years had the transmission go out. So we decided to spend a little extra money to buy a car that we thought would last our family a few years. We bought a 2006 Saab 9-7x (they are cheaper than trailblazers and envoys in my area), for $2,900 a little less than a month ago.
I checked the oil 2 weeks prior to this happening and it was at the perfect level. Oil pressure was good, oil life at 40%. Two days ago while driving in town I heard a ticking. I thought it was something that got stuck in my fan. When I looked, there was nothing.
I took the serpentine belt off and ran it for a second and the noise was still there. I checked the oil and I was 3 quarts low!!
I took it to two different mechanics for a diagnostic, both said it's definitely a rod bearing. We've put maybe 600 miles on it since we owned it.
My question is, is it worth it to try replacing all the bearings? Online they are $55-$60 for all 6. But then I still need to wonder why it burned or leaked all that oil in just 2 weeks. I didn't notice any puddles or leaks anywhere.
I thought about a used engine, but they are $1,500+ with 180,000+ miles around me. And we definitely can't afford a new engine.
Any advice or help is greatly appreciated.
 

·
Registered
2005 gmc trailblazer_ls
Joined
·
124 Posts
Regarding possible oil leak. Check oil pressure sending unit. It is located above oil filter. It may not leak when engine is not running , but when its running, defective oil sensor ofen will leak through the connector. There might be also other possibilities. Oil pan seal, drain plug, engine Burns oil. Start from the simplest things

Sent from my SM-G955U using Tapatalk
 

·
Registered
2008 gmc envoy_sle
Joined
·
631 Posts
sorry to hear about your trouble.

what is the mileage on the vehicle?

did you add the missing oil?
 
1 - 3 of 3 Posts
Top