Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just recently bought a 06 th since ive bought ny stabilitrak kept locking up...i mean i coukd drive absolutly no where my brakes were wore down to nothing so they were replaced....then all of a sudden i had no, i mean none ,zero brakes at all!! Replaced the master cylinder and it's been fine....now i just had 4 new tires put on the right sizes...and one of my tires keeps making a thudding noise as the wheels spins while im driving...ihave no clue wtf it is....then there's the fuel pump...so i think...nt car starts spitting and sputtering one day like its not getting any fuel like the filter is blocked i let it sit for 2 weeks fires up and ran fine for. 1 week then all of a sudden did it again....got it towed home left it sit for another week just for the hell of it i went and started it and it stayed running no stalling etc...ran for 2 weeks great....now all of a sudden doing same exact thing....the. Theres the power windows....the panel on the drivers side isnt working at all now the passenger side only works every now and then....but the back windows have t stopped working at all....i have checked and trouble shooted everything i possibly coukd with this car please if anyone can help with these problems in encountering please throw me some advice before i blow the car up !! Thanks in advance!
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
484 Posts
Welcome to the Forum!!!!

First, please let me ask you a couple of questions.

1) Do you have a code scanner/reader?

2) Do you own a digital multimeter?

3) Do you have any type of service manual such as Haynes, GM Factory Service Manual, Alldatadiy.com subscription?

4) How experienced are you with respect to repairing/maintaining vehicles manufactured since 2000?

Also, How about rewriting your posting and separating the different problems/concerns into separate paragraphs (for example one paragraph about the fuel problem, a second paragraph about the windows problem, etc. This would make it much easier for us to assist you.

Thanks and Good Luck!
 

·
Registered
Joined
·
1 Posts
Im just going to add to your BS that i experience myself with my 04 4.2 LS.
And how i mended a battery drain. I basically bought a heavy duty switch and now switch the negative off a new battery everytime i turn the POS off..some say this will play heck with your computer or heater fan motors and God knows what else but i was at the end of my rope with this piece of junk and its alot easier than jumping my car everyday which i have for the last 3 years..Just come straight off the battery negative hit one bolt on a heavy duty switch. put the old wires on the other switch bolt ( I took an addition 2/0 wire from this bolt to ground on the front frame).Works like a charm

 
1 - 3 of 3 Posts
Top