Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 6 of 6 Posts

· Registered
2003 chevy trailblazer_ls
Joined
·
559 Posts
Discussion Starter · #1 ·
So i brought my truck to the dealer and they told me it was the speed cluster, apparently they go bad on all trailblazers. thatll cost me 600 bucks so screw that. then i brought it to aamco they said it was my speedsensor and gonna charge me 200. so i got the speed sensor for 25 bucks from autozone. replaced it didnt work. did i do something wrong after installing it? or is it a good chance that it is the cluster. Thankyou
 

· Registered
2002 chevy trailblazer_lt
Joined
·
75 Posts
If it's the speedometer needle sticking, then it's the motor that controls the needle. Each needle has it's own motor. You can buy the parts off ebay for about $10 each. Or you can find someone on ebay who services the clusters for about $100-$150. You just need to decide how involved you want to be in the repair.
 

· Registered
2003 chevy trailblazer_ls
Joined
·
559 Posts
Discussion Starter · #4 ·
Thanks both of you, i searched its cheaper than purchasing a new cluster. I just gotta return this Speed sensor. No point in keeping it if thats not the problem. Or could it be that i take my dash apart alot and maybe i disconnected a wire back there?. Sometimes it turns on and works till 40mph then gives up, but its only when its cold out and the night before was humid. Iunno ill just go with what you both said. Thankyou again.
 

· Registered
2002 chevy trailblazer_lt
Joined
·
75 Posts
Mine started sticking this past November. I had to turn the key till all gauge lights came on and turn off. It gradually goes back to 0 mph after a number of turns. When I was ready to send it outto fix it, it stopped sticking...hoping it was a cold weather thing. Been working since it turned warm here...crossing fingers :weird::undecided
 

· Registered
2003 chevy trailblazer_ls
Joined
·
559 Posts
Discussion Starter · #6 ·
it first started happening around november as well. i went over the newport bridge and it messed up it was workin a little. an suggestions?if i have to result in buying a new cluster ill get the SS cluster but i dont want to.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top