Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
2003 chevy trailblazer_ls
Joined
·
559 Posts
Discussion Starter · #1 ·
Where can I locate my VSS on my 2003 Chevrolet Trailblazer LS, Rear wheel drive. 4.2L I6. I found 2 of them, Heres the link This is the one I need to REplace http://www.autozone.com/autozone/ca...ere=&searchText=speedsensor&_requestid=302732

I can not find it, just the one under my oil filter and the one half way down the tranny on the top of it. May I have a diagram or Some Info. The dealership wants to charger me 250 to put it in and its apparently like .4 hours of work. Thankyou.
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
:tiphat Welcome :tiphat .I don't have a picture, but it is in the tail shaft of the trans on the passengers side. It looks to be about six inches from the end of the trans with a wire connector on it. Remove the bolt, VSS and the O-ring. Install the O-ring on the new VSS, put a thin coat of trans fluid on the O-ring, install the VSS in the trans, tighten the bolt to 97 in. lbs. and replace the wiring harness. Trans fluid will leak out so be prepared. If you get a new O-ring with the new VSS, assemble it, lube it, and, get it ready before you take the old one out, you should be able to swap parts without loosing much fluid. :m2: Good luck.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
559 Posts
Discussion Starter · #3 ·
Okay turns out that was the wrong one lol, i bought the 4wd one. so i replaced the 2wd sensor. i replaced it the original was like metal the new one was plastic is it suppose to be? no fluid leaked out and the speedometer still doesnt work. whats the process of elimantion whats next?
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
365 Posts
Does your odometer/trip count up when you drive? If so, most likely a bad stepper motor on the speedometer gauge in the cluster. Very common on these trucks. Do a search on here for "replace bad stepper motor" and you should find a "how-to" to pull the cluster and solder in a new stepper motor. The replacement motor can be found on ebay for under $10.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
559 Posts
Discussion Starter · #5 ·
yeah everything else works fine, the miles keep counting rpms go oil pressure, gas, temp,boost., battery all work. should i just replace all the motors like it says or just the 1?:thx
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
365 Posts
yeah everything else works fine, the miles keep counting rpms go oil pressure, gas, temp,boost., battery all work. should i just replace all the motors like it says or just the 1?:thx
If the miles are counting up, your speed sensor is fine. It is up to you if you want to replace all the stepper motors or just the spedo. The new motors are a new design that are supposed to be address the sticking issue. If you don't want to have to remove the cluster again to change another bad motor later, then do them all.

Let us know how it works out!
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
559 Posts
Discussion Starter · #7 ·
glad to know someone has some knowledge on this issue, think i can get a stepper motor through the dealer? i have a friend that works in the parts department. maybe she can get a discount.
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
365 Posts
Probably not. The dealer does not service clusters, they replace them or send them out to Delphi to have them repaired. Most people who do this repair get the new stepper motors off ebay. I remember someone on Trailvoy reported getting all 6 for under $40 shipped.

If I ever have this problem, I will get the motors off ebay and repair myself.
 
1 - 8 of 8 Posts
Top