Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 9 of 9 Posts

· Registered
2004 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi everyone im new to this site and I am having trouble with my Trailblazer its an 04 I6 LS. I noticed it started shaking not to much but i can notice it and when i have the AC on it shakes a bit more and turns off on me. I took it to the dealer about a year ago and they cleaned the bodythrotle but it started up again like if the idle is not right... Any advice please...:undecided
 

· Registered
2007 chevy trailblazer_ls
Joined
·
184 Posts
Roadie is the GOD....clean the throttle body again:thumbsup:
Welcome to TRAILVOY!!!
 

· Registered
2004 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter · #8 ·
broke off the bolt

I cleaned the TB but then changed the spark plugs when i took off the old ones they were soaked in oil so went to a mechanic and realized my valve cover gasket is broken so have to repair. $180 plus i broke the bolt that hold the spark plug boot down and cant find the bolt by itself must buy the whole boot wich is around $80. If anyone knows were can i get the bolt by itself please advice... Thanks
 

· Registered
2002 chevy trailblazer_ltz
Joined
·
3,321 Posts
There have been others who have broken the coil pack bolt, but none that ever found the bolt by itself (as far as I know). I think your stuck buying a new coil pack.

BTW, before you start cleaning the throttle body, disconnect the battery (30-45 min). The PCM needs to be reset to factory default setting. The idle may be a little rough at first, but should smooth right out. If not, you have other issues.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top