Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 7 of 7 Posts

·
Registered
chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter · #1 ·
Any ideas?

I have an 02 Trailblazer. The motor is extremely rough almost to the point of dying when the AC is on and at idle. Like at a red light.

Turn the AC off, no problem. Turn the AC on, it lowers the RPM to 400RPM and starts to die. The AC works great. I get 19 MPG on the highway. It doesn't miss any other times?

What could it be? Coil? If so, how do I test it with an OHM meter? I don't have a scanner.

Thanks
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
5,269 Posts
what you describe- is a classic symptom of a dirty throttle body- and a recent battery disconnect.
 

·
Registered
chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks for the quick replies. It's been missing at idle for a long time now. Just now looking in to it. The batt died today and I replaced it. Figured I would try to figure out the miss while I was at it.

So yes the batt was disconnected but it's not the issue. I'll try the clean TB trick now. Thanks.
 

·
Registered
chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter · #6 ·
Just performed the TB cleaning. It was pretty dirty. 101k miles.

It seems a little better but there is still a noticeable stumble when the AC is on. High/Low RPM and them a stumble.

Maybe it will get better after the computer learns it again.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top