Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

21 - 30 of 30 Posts

·
Registered
2004 gmc envoy_slt_xuv
Joined
·
5 Posts
04 XUV SLT 4.2 2WD Bought new 8-04

Have 241K looks almost new, replaced tranny at 238K motor mounts, Plugs and cleaned throttle body often enough. Have not given in to replacing thermostat and probably will since I get "not to temp" code when it feels like it, I reset it and its happy until it isnt.

After motor mount replaced I still get vibration at low idle ( less than 700 rpm)
doesnt burn or leak oil, change every 5k or less.

Ideas re: vibration and low idle speed?
Kade 1006:thx
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2 Posts
Mileage on my 2005 Trailblazer EXT

Over 368,000. I can't get the official mileage since I have a cast on my right foot and wife has the car. All I know is that it's still the original engine 4.2L and the 4th transmission (make sure you get the updated 3rd and 4th gear in your rebuild).
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
5 Posts
2004 Trailblazer LT. Original owner. 170k. Never a problem. Changed fuel pressure regulator and all ignition coil packs last month. Otherwise regular oil changes, spark plugs every 90k miles and keep that throttle body clean!
 

·
Registered
2008 chevy trailblazer_lt
Joined
·
30 Posts
Bought an '08 TB 4x4 last summer and it's a trooper! With 166k on the clock everything (except the door seals) is as tight as can be. I'm casually going through and replacing all the fluids just because it probably needs it, but everything works as it should. Hopefully, I can double the mileage on it before giving it up.
 

·
Registered
Joined
·
2 Posts
You need to buy the original AC Delco motor mounts.

Have 241K looks almost new, replaced tranny at 238K motor mounts, Plugs and cleaned throttle body often enough. Have not given in to replacing thermostat and probably will since I get "not to temp" code when it feels like it, I reset it and its happy until it isnt.

After motor mount replaced I still get vibration at low idle ( less than 700 rpm)
doesnt burn or leak oil, change every 5k or less.

Ideas re: vibration and low idle speed?
Kade 1006<a href="http://forums.trailvoy.com/images/smilies/thx.gif" border="0" alt="" title="Thank You" >:)</a>
 

·
Registered
2006 gmc trailblazer_ls
Joined
·
177 Posts
My 06 denali voy is at 149,200 today. Plan on doing full trans service this weekend. Pan drop with filter replacement and all fluid exchanged. As far as i can tell its never been done. I bought it with 131,000 on it. Should be fine since it shift and drives great. Fluid it a reddish brown and doesn’t smell burnt so I’m gonna chance it.


Sent from my iPhone using Tapatalk
 
21 - 30 of 30 Posts
Top