Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 20 of 37 Posts

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #1
I have been having this problem for a few months now and its only getting worse. As soon as you start the truck and back out of the driveway all the dash warning lights start to flash on and ding. The dic flashes from driver 1 to unknown driver. Now lately About 1 in 5 times i start the truck there is no dash activity at all....except for turn signals and high and low beams. I have replaced the battery last month, checked the voltage off the battery,12.6 when truck is off and 14.5 volts terminal to terminal when truck is on. So i dont think its the alternator, and it now seems to have developed a parasectic drain on the battery, its dead if you dont drive it everyday. Right before it starts dinging it seems that the amp gauge dips down low..for a second or 2 then bounces back to 14(that is when the dash is on).....could this be a ignition switch?...im grasping at straws here....only seems to be getting worse....thanks for any help.
 

·
Banned
2005 chevy
Joined
·
6,469 Posts
Ignition switch would be a good start (and least expensive part swap @ about $35) They tend to flake out and cause a bunch of weird electrical issues.
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #3
Now if i replace the ignition switch, is it going to screw up my pass lockout system and screw with the security stuff. I have heard sometimes after you replace it, it totally kills the truck because it thinks someone is trying to steal it.
 

·
Banned
2006 chevy trailblazer_ss_lt
Joined
·
5,895 Posts
what you are talking about is in the key cylinder, not the switch, so there is no worries
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #5
awesome....i was nervous i was gonna lock my truck out and really screw it up bad. Does the wiring just go bad in them or is it something mechanical on the switch?
 

·
Banned
2006 chevy trailblazer_ss_lt
Joined
·
5,895 Posts
heres what mine looked like taken apart

the discoloration of the far right lead (in this case it is one of the run circuits) makes me believe it wasn't making contact properly and heated up to failure
 

·
Registered
2004 isuzu ascender
Joined
·
8 Posts
Don't even bother switching the switch, I did and still have the same problem. I've had this problem over 3month now, no one have come up with a solution. I tried everything on this forum and nothing, I am going to take it to the shop soon.
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #8
im gonna change the switch......and see what happens....i have heard its a 50/50 shot......if this doesnt work i guess its gonna be a full new wireing harness....i swear i wanna rent a back hoe and dig a big hole and bury this truck. If the ignition switch doesnt work.....its got to be a dead short somewhere.....and that could be anywhere. grrrrrrrrrrrrrrrrrr
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #9
ok so i took the truck to a shop to have the charging system checked, battery tested perfect as did the alternator. I put the new ignition switch in....its better but i still get the dash messing up sometimes. I checked as many grounds as i could find for corrosion, and cleaned them. Still as im driving the amp guage will bottom out for a few seconds then bounce back to normal...it seems when this happens is when all the dings and alarms go off. Very sporadic...with no ryme or reason, im lost on this one....seems like something is not grounded right.
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #11
ok so i dont know the rules here that well lol. Im still trying to trouble shoot it, im gonna check the g201 ground tomorrow,im just confused to the amp guage bouncing...at night when it dips my head lights remain strong not one little dim at all. Is it possible a bad ground could cuase the battery to drain also?...when i had the charging system checked it showed no parasectic drains....i think it was .004 amps or something ..i have to check
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #13
Im onto something new....gm mechanic told me to check the rear hatch area..its a known problem that the wires can get broke or worn there...and it will affect the dash board
 

·
Registered
2004 isuzu ascender
Joined
·
8 Posts
Any luck? My buddy had the same issue and he said that there was a siruos or whatever that box for the digital radio behind the lighter plug in the dash and that he unplugged it and it fixed the problem. It was a silver box near the radio. I dont have that box so I am still looking for my problem.
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #16
Found the g201 ground....not too bad getting access to it, but still didnt fix anything. Now when i turn the key off, everything shuts off except for the gear selection light on the dash and the battery icon on dash....i have pulled the ignition switch and put it back in still nothing...these lights stay on till the battery drains....grrrrrrrrrrrrrrr
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
168 Posts
I have the same problem but it only happens in HIGH HUMIDITY CONDITION (heavy rain or after a rainy day) but I have no solution for this weird issue yet.
 

·
Registered
2004 chevy trailblazer_lt_ext
Joined
·
33 Posts
Discussion Starter #19
Still nothing on this.....im about to give up and take it to the stealership
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
If anything stays lit when you take the key out of the switch, I'd suspect you have it installed with a one-tooth-off issue on the gear.
 
1 - 20 of 37 Posts
Top