Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Well, here it is guys: Recently noticed on Fri night that the auto lights on my wife's '05 Trailblazer weren't working. Next day ck'd fuses: good. Moved on to checking bulbs: burnt. Ok, replaced bulbs, and nothing occured. They didn't work in the manual "on" position either. Found the HDM and switched it with the cooling fan relay: only the passenger side worked - only when the switch was in the "on" position - not in auto/DRL mode. Swapped bulbs to make sure that the driver side wasn't bad, but it worked the same way.

Sooo... it appears that the HDM certainly has issues, but I'm not sure that explains why it's only working manually and only on the passenger side once it's switched. Any ideas why and/or what might fix it? (BTW, after monkeying around - ONLY with HDM and fuses 3 and 6, ABS and brake warning lights are on, but everything seems to work fine. WTF?) :crazy:

Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Update

Well, after going out and checking connections to the bulbs again (nothing seemed amiss) then swapping HDM and Cooling fan relays again, both lights began working, but still only in manual mode. Parking brakes also don't seem to be coming on now, but were before. Aaarrgh!!!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
WooHOOOO

After screwing around, figured that at a bare minimum, the HDM was bad and found one in stock at a Chevy dealer. Replaced it in the parking lot and... Voila! All is right with the world again; DRLs and everything are back to normal. That one relay was causing numerous odd activity. Thankfully, that was all it was. Hope this helps save someone else a few hundred, as it did me. :woohoo:
 
1 - 3 of 3 Posts
Top