Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 05 envoy.. changed fan clutch and still get the loud jet noise. I have read it could be the blower? acutator? My vents dont work well unless on highest setting. Heellllppp I need this to be done and over with lol
 

·
Registered
Joined
·
321 Posts
Man! I wish I had checked the order form for that jet engine sound in my '05 TB! Jealous!

IF this is a straight 6, there are a lot of troubles with the plenum-to-manifold formed silicon gasket. A big vacuum leak can cause a lot of vacuum controlled device problems.... like the HVAC and even the PB if the leak is big enough.

It MAY be just a partially collapsed vacuum hose too..... the next sentence is the answer.... read on.....

I'd stick a piece of plastic hose in your good ear and the other tubing end would go all over the engine while it's running to find the source of the jet engine.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Now today it hasnt done it at all. Ugh idk but everything I've read points to fan clutch. Just got an oil change. New spark plugs. Oil filter. Air filter. Fuel filter. Fuel pump and sending unit. Fan clutch. Lift kit. New struts. New belt tensioner. New idler pulley. So if anyone has any experience with this loss of power and loud acceleration at random times, please help! Seems to go away when I hit like 40 mph since I got the new clutch. Didnt notice it before but who knows.
 

·
Registered
Joined
·
321 Posts
Well..... kep that piece of tubing in the car and when you hear the noise sgsin, shove it in your ear and go noise hunting

If you think the fan clutch is the problem.. unplug it whe the noise appears.... and listen if it goes away or not.
 
1 - 4 of 4 Posts
Top