Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 6 of 6 Posts

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
2 Posts
Discussion Starter · #1 ·
So i was doing some AWD cookies. I did have the wheel at full lock (error on my part) anyhow there is now no power assist. Did I blow out the pump?
 

·
Registered
Joined
·
8,781 Posts
have you checked the fluid level?

check to see if the PS hoses are kinked in any way..

check the serp belt and tensioner

you may need to bleed the system.. air may have gotten in when you were at full lock (not probable but possible)
 

·
Northwest Chapter
Joined
·
11,824 Posts
I did this with my 02 TB a few years back, was doing doughnuts on a sand covered asphalt parking lot, front wheels came off the sand onto the asphalt and tore the wheel from my hands. Sheared the power steering pump pulley off the input shaft, had to buy a new pump.

Do the checks Majestic recommended, then pull the serp belt off and check on the pulley.
 

·
Registered
2006 chevy trailblazer_ss_ls
Joined
·
2 Posts
Discussion Starter · #4 ·
Well guys, pulled off my belt, and figured i would give a little tug on the pully. Well it poped off, along with the shaft that should be in the pump. Kind of a wimpy looking part if you ask me. What dosn't gm know we all like to do AWD cookies.??
 

·
Northwest Chapter
Joined
·
11,824 Posts
Well guys, pulled off my belt, and figured i would give a little tug on the pully. Well it poped off, along with the shaft that should be in the pump. Kind of a wimpy looking part if you ask me. What dosn't gm know we all like to do AWD cookies.??
Woohoo another one bites the dust! Same thing happened to me, glad to know Im not the only one who's done this now. And I was in 2HI at the time too... just hope the one on my SS is beefier because eventually I will be doing AWD burnouts and drifting.
 

·
Registered
2003 gmc envoy_sle
Joined
·
5 Posts
Awsome, that must be what i did. i did a spin around in my dads driveway on the ice and when i straightened out the power steering had stopped working. i guess i just need to replace the pump now huh..:(
 
1 - 6 of 6 Posts
Top