Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
Hey I'm having an issue with my trailblazer. I was driving last night and once it got dark I noticed my headlights wernt working, but the high beams are.... As well as one of the little clear bulbs that are on the side of the headlight with the orange lens also is no longer working and one of the lower ones with the big orange buld isn't working but they work to indivate... Then all of a sudden I noticed the abs and parking brake light stuck on??

Anyone know what's going on?

Thanks.. Again sorry for bad grammer and stuff I post this off a cell.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Probably all separate issues. Let's work on the low beams first, since that's critical to safety. There are two fuses, one for each side of the low beams, front fuse block #3 and #6. Check them. Check the bulbs if you have a meter, too.

It may also be the low beam relay: #46. You can interchange it in the front fuse block with the identical relay #45, which runs the fan clutch. Even if the relay is dead, it won't overheat for many minutes.



The other lamps are probably just that - bad lamps. Check them with a meter and swap if they're open.

Assuming your parking brake isn't on, you may have to dig deeper to troubleshoot that. Do you have a meter and know how to read a schematic?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top