Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi,
I hope someone can help about a month ago my keyless doorlocking stoped working (both key fobs) I have been using the master door lock/unlock button on the drivers door which has been working fine. Unfortunately at the weekend the lift gate door would not unlock. I manually released it from inside and tried it again but the door lock will not respond to any commands from the master switch. I have done a voltage check at the solenoid but have no volts at either closed or open side. An addition fact is the rear wiper or washer has stoped working as well. I am wondering if the lock solenoid has some how messed up the logic for the liftgate module as this is preventing the the wipers because it thinks the door is open some how ? I do not have a lift gate warning light (either open or closed)
Any ideas there are a couple of microswitch cables that feed into the module from the door lock but I can not find any wiring info about them ( source haynes manual)
Please can anyone help, Hope this makes some sense.
Dave
 

·
Banned
2003 chevy trailblazer_lt_ext
Joined
·
771 Posts
Hi,
I hope someone can help about a month ago my keyless doorlocking stoped working (both key fobs) I have been using the master door lock/unlock button on the drivers door which has been working fine. Unfortunately at the weekend the lift gate door would not unlock. I manually released it from inside and tried it again but the door lock will not respond to any commands from the master switch. I have done a voltage check at the solenoid but have no volts at either closed or open side. An addition fact is the rear wiper or washer has stoped working as well. I am wondering if the lock solenoid has some how messed up the logic for the liftgate module as this is preventing the the wipers because it thinks the door is open some how ? I do not have a lift gate warning light (either open or closed)
Any ideas there are a couple of microswitch cables that feed into the module from the door lock but I can not find any wiring info about them ( source haynes manual)
Please can anyone help, Hope this makes some sense.
Dave
Do a search, there are lot of others with this issue. Maybe a break in the wire running from the liftgate thru to the headliner. The wires break inside the sheild so it very hard to find them.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Thanks menthol,
I have looked through the tread you gave me, the thermal expansion might be a cause because it stoped working on a very hot day, I will look at the module, but my gut feeling is that it has something to do with the position sensor in the liftgate lock solenoid. I can't find a wiring diagram for the position sensors just the solenoid. If I had that i could short out the closed loop and simulate it and see if that worked.
Does anyone have a decent wire diagram for the door lock system ?

Many thanks again this is a great forum.
Dave
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top