Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 6 of 6 Posts

·
Registered
2004 chevy trailblazer_lt
Joined
·
417 Posts
Discussion Starter · #1 ·
im trying to find the license plate fuse i just bought new bulbs and for some reason only one is working and i have no idea how read the the things on the fuse box??? please help:confused:
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
It is much easier to read the descriptions in your owners manual. But I believe there is only one fuse that covers both license plate bulbs. If one lights-up the fuse is good. Try switching bulbs. You my have gotten a new one that was bad from the factory.:m2: .IIRC, they are on the same circuit as the rear parking lights.
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
I didn't know you were talking about LED's. You know, first of all, that they have a + and - and only work in one direction, right? OK. When I put the LED's in my Envoy, I had to move the wires on some of the LED bases to make contact with the connectors. Try that and make sure the + and - are in the right way.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
417 Posts
Discussion Starter · #5 ·
:mad:i tried that earlier to see if i put the one in wrong but still nothing that was the reasoning behind me swicthing the olod ones out and the first night they were fine but now the same side is going out. i messed with it a lil bit and it started to work and stopped??????:hissy: i dont understand why!
 
1 - 6 of 6 Posts
Top