Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,003 Posts
Discussion Starter #1
I have some 37W LEDs as auxiliary driving lights (they light up deer and cow eyes on the roads - all of which have the Right-Of-Way here).

When the LEDs are switched on, I lose my FM radio reception.

Turn them off - and the radio comes back.

Whazzup with that?
 

·
Registered
2002 Pewter ls with automatic trans. 4x2, gray cloth interior.
Joined
·
38 Posts
Interesting. I had led low beams for a few months before I reinstalled them back onto my corvette but I didn't have any radio reception issues. Perhaps the wiring has something to do with it or grounding issue? With the C5 Corvette which is what I have, there's tons of electrical issue they have and bad/corroded grounds are a big thing.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
802 Posts
It sounds like the LED assemblies are generating RFI which is overwhelming the FM side of your radio. How does the AM side of your radio work? Also, do you have a portable, battery operated AM/FM radio you can walk around your TrailBlazer with to see if it's FM reception gets blocked when the LED lights are activated?

If the portable radio is affected as well, then my suggestion is to see if you can wrap some insulated wire mesh around the LED bases with a wire electically connected to he mesh and grounded as close to the LEDs as is possible. Sort of a cheap Faraday Cage.
 
  • Like
Reactions: Rwta98
1 - 3 of 3 Posts
Top