Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2002 chevy trailblazer_ltz
Joined
·
20 Posts
Discussion Starter #1
I have an early model year '02 Trailblazer LTZ, it now has about 100,000 miles on it and has the 4.2 I6. The issue I am having wasn't there when I bought the vehicle a year and a half ago (with75,000 miles on it).

This just started this winter, when I start my vehicle in the morning i hear a knocking noise, sounds like a diesel engine at first for about 5-10 minutes then goes away. I have read threads on this issue before, but the latest suggestion was in '05. I know what it could be, i have read the horror stories of what happens and i have read what could have been done about it back in '05.

I am wondering if there is anything that can be done about it...now that it is almost 10 years old and has over 100,000 miles on it, or am i SOL.

I love my TB, i just need it to last about another year until i can buy something new
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
64 Posts
I bought mine with 90k and it was doing the same thing when first started, especially in colder weather. Of course I bought it in August so I didn't notice the noise. Now I have 160K on it and it still does it at first start up especially when its cold. As it warms up it quiets right down. From what I have read if it goes away when warmed up then don't worry about it. It the noise doesn't go away then there may be problems. Someone correct me if I'm wrong here but the way I understand it, it has to do with piston slap and as the metals warm up and expand everything fits better and quieter.
Tom
 
1 - 3 of 3 Posts
Top