Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 8 of 8 Posts

·
Registered
2002 chevy trailblazer_ls
Joined
·
10 Posts
Discussion Starter · #1 ·
I just got a keyless entry remote and cannot get it to program. I have used the instructions on programming that are on these forums but they don't seem to work correctly for me. When I try to program; it does the door lock cycle, but about 2 seconds later the door locks cycle again. I have another remote and I haven't even tried to reprogram it (it should reset to my understanding once I initiate program mode) but it still works even after attempting to reprogram. I have heard that possibly the problem could be connected to the liftgate module? I just recently got my trailblazer and the list of problems just continues to stack up. Can anyone help me diagnose this problem?
 

·
Registered
Joined
·
2 Posts
Hi

Most remotes can be programmed manually at home without any tools or technical skills.
If you need to just order the instructions please check our website at
http://www.carandtruckremotes.com/programming-instructions.html

If your car responds to programming instructions but the remote does not respond, it is most likely one of the following reasons
1. The battery may be dead.
2. Try the instructions again - sometimes it takes more then one try
3. If it still does not work, the remote might be broken or you have a wrong remote.
If your car DOES NOT respond to programming
1. It may not be equipped with keyless entry system - please check with your local dealer
2. There might be a problem with your RKE module � please check with your local dealer
3. You may have the wrong set of programming instructions � please check with your local dealer
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
The liftgate module is indeed where the receiver is for the factory keyless remote. It may need to be programmed by the dealer to support an option it didn't come from the factory with. GM does this to make sure they get all the money out of you possible.

The LGM also controls the rear wiper motor. Thanks for telling us that - it's quite connected.

The rear washer fluid pump is on the reservoir tank up front, so that's not involved in the LGM.

You may have simply lost a fuse. Check #3 and #19 in the rear fuse block. Or the wires at the hinge area might have flexed and gone bad. Are you a DIY person or have an electrical-experienced person to call on?
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
3 Posts
Hi. Have you found a solution for your problem yet? Because I have the same issue with my 2003 TB LS. When I try to program the remote, I have the lock and unlock cycle, and after 2 or 3 seconds it does it again. My tailgate wiper is working ok, and all the locks are working ok. I just cannot program the remote. I will check the wiring to see if something is broken (I read that this is a common issue).
Thanks in advance....
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
10 Posts
Discussion Starter · #6 ·
Yes, actually I did find the problem. I took my 02 TB into the dealer and they told me that my LCM (Liftgate Control Module) was fried. I had them replace this and it was supposed to fix the rear windshield wiper and the keyless remote entry. However, after replacing the LCM it only fixed the rear windshield wiper... So they were pretty much stumped but tried swapping out my BCM (Body Control Module) and sure enough that fixed the keyless remotes. So apparentely my LCM and BCM got messed up somehow, they think maybe a bad jump start or something. Hope this helps. By the way I didn't have the money to buy the BCM to install so if anyone has a BCM for sale or knows where I can get one relatively cheap that would be great! :thumbsup:
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
10 Posts
Discussion Starter · #7 ·
Oh, in addition before I had them try to figure out the problem I took my TB to the dealer and tried to have them manually program it for me. At my dealer this was free of charge so it might be a good thing to try. For me it didn't work (due to the LCM), but it might be worth a try.

After the new LCM was installed they were able to program my remote but only the panic button works. Apparantely the BCM controls the other functions...
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
3 Posts
Thanks a lot for the tips. I just checked all the wires from the tailgate and everything is ok. I was looking @ EBay for BCM's, and you can get one (used, of course, but with warranty) for $60, shipping included. Not bad. I'm not sure, but I think it needs to be programmed for your TB, am I right? Good luck and let me know as soon as you get it fixed. Best regards...:tiphat
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top