Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

· Registered
2003 chevy trailblazer_ls
Joined
·
426 Posts
Discussion Starter · #1 ·
bought a K&N 77 series about a month ago, installed it, works great except one thing! when i first start the car when it is cold, when the idle starts to come down to about 750 rpm's i start to hear the heat shield rattle for about 20 seconds.

after that i don't really hear it rattle anytime else, except when i have my ac running, when im at a full stop and go to give some gas around that same rpm it will faintly rattle then stop.

can anyone help me find a way to stop the heat shield from rattling ?
 

· Registered
2007 gmc
Joined
·
159 Posts
I have a K&N but on a different truck. I put neoprene/rubber washers that you can pick up at the hardware store on each side of the bracket that bolts to the body. Have not had any issues with it.
 

· Registered
2003 chevy trailblazer_ls
Joined
·
1,248 Posts
This may be an indication that you are due for new motor mounts. They are normal maintenance parts, and you might expect to change them some time before 100K miles.

Otherwise, as indicated, isolate the mounts with rubber. I had to do that somewhat with my True Flow intake setup as well. It was making noise as it entered the factory air box (True Flow uses the factory box instead of an air dam like K&N) and I used some self-stick rubber door strip to wrap around the tube where it enters the box. Helped a bunch.
 

· Registered
2003 chevy trailblazer_ls
Joined
·
426 Posts
Discussion Starter · #4 ·
thanks for the tips, i think i am going to try and get me some rubber washers like you were saying, see if that does it.

as long as the heat shield doesn't rattle, i think it will be fine.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top