Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 03 trailblazer instrument cluster is driving me crazy. Sometimes when i turn the ignition to on(not start) all lights and gauges turn on and work perfectly fine, and the cluster will proceed to work perfectly (while driving too) for a random amount of time. Then suddenly ill turn ignition to on and only the check engine light will display and nothing else. When this happens none of the gauges work at all while driving. The cluster is still illuminated and directional and hazard lights work but thats it. No gauges at all. Then just as randomly as is stopped working, it starts working. It only happens when turning key on and off, never during travel. Each time it last a day to sometimes weeks either working or not. I also have an after market alarm installed (from best buy i believe) and the alarm indicator light is always solid. The remote works for door locks but the alarm itself doesn't sound when opening a locked door. Before I start ripping out the dash and inst. cluster i figured i get some input first. Also new radio was put in by previous owner, works fine except for clock always resets when car is off, all other memory is kept.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
1 Posts
I had to get the entire instrument cluster replaced on my 03 TB. This was in 2014. The speedometer stopped working. I found an authorized mobile repair guy who specializes in doing this. He drives to where you are. Maybe there is a repair service like that where you live.
 

·
Registered
2005 trailblazer_lt
Joined
·
124 Posts
I've got a few spare clusters,...... If you find that you need a replacement, just send me a PM message.

:cool:
 
1 - 3 of 3 Posts
Top