Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 6 of 6 Posts

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
1 Posts
Discussion Starter #1
My instrument cluster in my 05 EXT is all wonky. My oil pressure and temperature gauges are shot and stuck in the same position. My speedo has a mind of its own, starting at all different points, 35, 70, 130. What can I do to fix this besides sending it in, I have been soldering since I was 7 and I can't give up my cluster for a week. Thanks for the help.
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,469 Posts
If you are comfortable in your soldering skills, buy a set of stepper motors on Ebay and remove the cluster from the dash, and go at replacing all the stepper motors. Check YouTube for how-to videos.
 

·
Registered
2003 chevy trailblazer_ltz
Joined
·
153 Posts
Stepper motor problems are
1. Common as dirt
2. Easy and inexpensive to fix
3. While you're in there, solder in new light bulbs.

You have all the symptoms of failed stepper motors. If you want to double-check, grab a REAL scan tool, set it up to communicate with the instrument cluster. Use the scan tool to run the gauges from bottom-of-scale to full-scale while you watch the needles. The gauges should have no problems swinging from one end to the other at the command of the scan tool.
 

·
Registered
2005 trailblazer_lt
Joined
·
112 Posts
The cluster is pretty simple to remove and if you buy a rebuilt kit in advance and have the soldering tools already,.... replacing the steppers and some new bulbs shouldn't take longer than an evening to complete. If you don't want to deal with it --- send me a PM I've got a few used clusters available,... just be sure to include your Mileage and your ZIP code in your reply. ( I've got a few clusters and would try to find one with similar mileage. )



:cool:
 
1 - 6 of 6 Posts
Top