Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
3 Posts
Discussion Starter · #1 ·
I installed a new head unit today. I go out to start my truck to leave and my radio is on and I cannot start the truck. When I try to crank it I get an unknown driver on the instrument panel and nothing happens.

Earlier today after installing the unit I was going to a restaurant, made a right turn and all of the instrument panel lights and gauges went off and on. I believe the lights on the thermostat went off and on. I'm preempt sure the headlights flickered as well.

I know that I did not tighten the negative terminal on the battery as tight as it was when I took it off. I tightened the negative terminal and tried again and no luck.

As I'm typing this I have the negative terminal unhooked. I am going to try and see if I can reset anything.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
3 Posts
Discussion Starter · #2 ·
unhooking the negative terminal and letting it sit for about a half hour did the trick for now...
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
672 Posts
I installed a new head unit today. I go out to start my truck to leave and my radio is on and I cannot start the truck. When I try to crank it I get an unknown driver on the instrument panel and nothing happens.

Earlier today after installing the unit I was going to a restaurant, made a right turn and all of the instrument panel lights and gauges went off and on. I believe the lights on the thermostat went off and on. I'm preempt sure the headlights flickered as well.

I know that I did not tighten the negative terminal on the battery as tight as it was when I took it off. I tightened the negative terminal and tried again and no luck.

As I'm typing this I have the negative terminal unhooked. I am going to try and see if I can reset anything.
If the radio was on, when you went to the truck, then your key was on, as well?

If key was on, then it may be a security issue that is preventing your T.B. from starting.

Here is a procedure to correct the no start, IF THE SECURITY IS THE CULPRIT.
http://forums.trailvoy.com/showpost.php?p=276533&postcount=24
 
1 - 3 of 3 Posts
Top