Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Not sure what to do I am driving and when I come a stop my rpms drop and then truck cuts off and it's also happened while turning and I need to get this issue fixed asap thanks in advance
 

·
Registered
2004 Trailblazer LS 4x4, 4.2L:, 2016 ATS-V, 2014 CTS-V Wagon, 2018 Audi A7
Joined
·
150 Posts
Throttle body been cleaned? Just one thought.
 

·
Registered
2004 Trailblazer LS 4x4, 4.2L:, 2016 ATS-V, 2014 CTS-V Wagon, 2018 Audi A7
Joined
·
150 Posts
Yes, codes will definitely be helpful.
 

·
Registered
Joined
·
1 Posts
When the code P0304 is set in the Powertrain Computer, it means that the Misfire Monitor has detected more than a 2 percent variance in RPM between the firing of any two (or more) cylinders in the firing order.
The Misfire Monitor constantly
checks the rotational speed of the Crankshaft by counting the pulses of the Crankshaft Sensor. The Monitor wants to see a smooth increase or decrease in engine RPM
Easy fix - camshafr sensor easy replacement and not expensive
 

·
Registered
2006 Chevrolet Trailblazer LS
Joined
·
23 Posts
Not sure what to do I am driving and when I come a stop my rpms drop and then truck cuts off and it's also happened while turning and I need to get this issue fixed asap thanks in advance
Your description is pretty vague, so I'll throw in my $0.02. Does this issue manifest only when coming to a stop? When the engine is warm or only when it's not up to temp. Is the transmission letting go when you slow down? i.e. does it jerk as it comes to a stop? When was the last time fluid checked/changed. How many keys hanging from your ignition switch? Have you tried to duplicate the issue in the driveway manipulating the ignition switch and the tilt wheel?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
Your description is pretty vague, so I'll throw in my $0.02. Does this issue manifest only when coming to a stop? When the engine is warm or only when it's not up to temp. Is the transmission letting go when you slow down? i.e. does it jerk as it comes to a stop? When was the last time fluid checked/changed. How many keys hanging from your ignition switch? Have you tried to duplicate the issue in the driveway manipulating the ignition switch and the tilt wheel?
All the fluid are fine and it will do it when I 1st up and then it sometime will do it after I have been driving for a long time.And I have only 3 keys truck house keys that's it nothing major hanging and no jerking just get real smooth cause the motor cut off
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
Your description is pretty vague, so I'll throw in my $0.02. Does this issue manifest only when coming to a stop? When the engine is warm or only when it's not up to temp. Is the transmission letting go when you slow down? i.e. does it jerk as it comes to a stop? When was the last time fluid checked/changed. How many keys hanging from your ignition switch? Have you tried to duplicate the issue in the driveway manipulating the ignition switch and the tilt wheel?
Nope the trans does not jerk or anything like that and yes it only happens when I come to a stop. But it only does it sometimes not every single time I am driving. But its like when I start out driving its fine but if I stop the car to go in like a store or something when I get back in to start it up it will stall out then and I have to step on the gas to get it to start up and it will still idl down then stop and I would have to start it back up and step on the gas and while the RPMS are still high put it in gear. And then once I start going and stop it will idl down and stop or if I slow down to turn it will cut off..I am going to try and change the Crank senor I have been seeing that a lot I have already changed the CAM sensor
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
307 Posts
I am going to try and change the Crank senor
I would reccomemd NOT doing this unless it has been tested and proven to be bad. Why? Replacing the crank sensor requires a CASE relearn and that can only be done with a high end (expensive) scan tool
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Ok let me see if I am able to run up to AutoZone and scan for codes
Ok the only code that came up was camshaft sensor clutch fan sensor and I changed the camshaft sensor and had it relearn it I changed the throttle body changed the air filter out in brand new spark plugs..when I am start it up in the driveway way it will run smooth idle at 800 RMS no pro but soon as I drive off and come to a stop it stalls out. What else could it be??
 
1 - 15 of 15 Posts
Top