Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
2004 chevy trailblazer_lt
Joined
·
14 Posts
Discussion Starter · #1 · (Edited)
Oh Boy, While looking for a hot when key on wire to hook up my mirror, I grounded with a circuit tester what I thought was the wiring connector for the fog lights which were not installed on my Trailblazer. It was the wire that was connected to the black panel that is below the knee bolister. I have a feeling it was for the computer programmer. Now the radio is going crazy, the headlights just flickered on and off. The car starts and runs but the only guages working are the odometer and the tach. The check guages light is on. I unhooked the power for awhile and will see what happens. What do you guys think.:mad::confused:

Additional Info: I grounded the wires that were in the plug that you cannot access without dropping the black panel.
 

·
Registered
2006 chevy
Joined
·
2,079 Posts
Check your main fusable link under the Hood. You could have blown that. I had a car at work blow the fuseable link, but it never really blew just cracked and it cause a whole lot of werd issues. The connector is under the fuse cover under the hood. It should say 125A on it.. Check the window as see if it isn't blown.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
14 Posts
Discussion Starter · #3 ·
Check your main fusable link under the Hood. You could have blown that. I had a car at work blow the fuseable link, but it never really blew just cracked and it cause a whole lot of werd issues. The connector is under the fuse cover under the hood. It should say 125A on it.. Check the window as see if it isn't blown.
I just checked the fuse, it appears just fine. I will leave the battery disconected for atleast an hour to see what happens.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
14 Posts
Discussion Starter · #4 ·
Oh Boy, While looking for a hot when key on wire to hook up my mirror, I grounded with a circuit tester what I thought was the wiring connector for the fog lights which were not installed on my Trailblazer. It was the wire that was connected to the black panel that is below the knee bolister. I have a feeling it was for the computer programmer. Now the radio is going crazy, the headlights just flickered on and off. The car starts and runs but the only guages working are the odometer and the tach. The check guages light is on. I unhooked the power for awhile and will see what happens. What do you guys think.:mad::confused:

Additional Info: I grounded the wires that were in the plug that you cannot access without dropping the black panel.
FIXED!!! Apparently that little white clip needs to be into the harnass. I didn't even notice metal prongs sticking out of it. :woohoo:
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
That's a Splice Pack for half of the modules in the vehicle that have a serial data bus to communicate with each other, including the gauge cluster and radio. There's another one of them hidden under a carpet flap under the back seat.

Best place for a hot when ON wire is the ignition switch, although I've posted a chart of fuses you can tap off of in other threads.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top