Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
2002 chevy trailblazer_lt
Joined
·
37 Posts
Discussion Starter · #1 ·
I have an 02 Trailblazer....I was fixing one issue (for which I needed to disconnect the battery) when I finished up and reconnected the battery, my Service 4WD light came on and stayed on...it worked just fine before that! When I start the car, the lights come on above the switch, but after that, nothing! Every once in awhile the red "N" is lit up...very weird. Can anyone tell me where I might start?!
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
I moved this to the 4WD forum for better exposure, but this system is my specialty. Some 2002 TCCM (transfer case control modules) had a hardware fault that they failed to wake up with the ignition. When the BCM (body control module) lost track of it, then the Service 4WD light comes on. There is also a dealer-installed flash update to try to make the module wake-up more reliable.

Before you put in a new TCCM or pay the dealer for the update, just try a power cycle on the TCCM, which is to remove fuse #8 under the hood for 30 seconds with the ignition off. Then reinstall it, and turn on the ignition but don't start the vehicle. If the Service 4WD light doesn't come back on, you win. Then try the various 4WD modes with the selector switch and listen for the two different motor sounds under the vehicle.

If the fuse reset doesn't work, you probably need a new TCCM and the dealer reflash.
 
1 - 3 of 3 Posts
Top