Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

21 - 40 of 704 Posts

·
Registered
2009 chevy
Joined
·
6,431 Posts
hi, great forum, thanks for all the great info. i hope this thread is the answer to my problem and i hope others can give me ideas.

2003 sle envoy. i recently (well last few months ) am only able to have A/C or heat come out of the front vents on the 3rd setting on the nob. A/C and heat works but only blows out strong on 4th and 5th setting and NOW today only on the 5th setting. before i had the battery die and had throttle problems and was able to fix it with a good cleaning of it...thanks to the forum. do you think its the " mode door actuator " that needs to be replaced? i too have had the clicking sound but strange as it might be only time i hear it is during the winter months. thanks for any help and great forum with great info.
Hi, welcome to the site.
The mode doors only control the direction of the air flow (floor/vent/dash), have nothing to do with the fan speed.
It sounds like you are having a problem with the fan speed control module. I think it's called a blower motor resistor assembly. Very common problem, it's a $25.00 fix (if u do it yourself) and located under the dash, behind the glove box. Lots of info on here, and some pictures. Try a quick search, the more recent threads are the ones to view.
You may also have a mode door problem, but the speed thing is the resistor assembly.
 

·
Registered
2003 gmc envoy_sle
Joined
·
19 Posts
thanks for your reply. after posting i did some more reading and there was someone who also had or has the same problem. the vent would or seem to not have any air/heat/ac coming threw when i turned the nob on. setting 1,2,3, now 4 acts like the off position and 5 is the only setting that pushes anything out. i'm hoping that the person who also had the same problem post a reply. do you know of any good places in Canada to buy parts besides places like CrappieTire? i also need to replace the spare tire carrier. seems like this truck needs some upkeep.

thanks
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
605 Posts
All the work is done from the drivers side.



Read my initial post again; it was due to the dash vents not working. The actuator door allows air to go to the dash vents and floor vents.
The problem with mine is the dash and defroster vents work, but I have no floor vents.
 

·
Registered
2002 olds bravada
Joined
·
42 Posts
Hot & cold at the same time

I've been searching high and low, and I'm hoping the pictures here will help. I get air through the various vents, but on the drivers side it's only warm air while the A/C works fine on the passenger side.
By looking at the directions and pictures, can I assume that the upper actuator is the one that I will need to replace to get cold air out of the driver's side vents?
The pictures do help, if it wasn't for them I wouldn't know what to look for. My Chilton's manual is useless in providing any help on this subject.
 

·
Registered
Joined
·
7 Posts
I've been searching high and low, and I'm hoping the pictures here will help. I get air through the various vents, but on the drivers side it's only warm air while the A/C works fine on the passenger side.
By looking at the directions and pictures, can I assume that the upper actuator is the one that I will need to replace to get cold air out of the driver's side vents?
The pictures do help, if it wasn't for them I wouldn't know what to look for. My Chilton's manual is useless in providing any help on this subject.
Same here, drivers side blazing hot, passenger and rear nice and cold. This also happened the same day the battery had to be replaced. Has anyone had this problem and fixed it?
 

·
Registered
2002 gmc envoy_slt
Joined
·
303 Posts
The problem with mine is the dash and defroster vents work, but I have no floor vents.
I have the same problem.....I also cannot turn the defroster vents off if I want.

I did replace the mode door actuator and it clicks less but still does not work correctly.

I think the actuator works but the door itself cannot move the whole range for some reason.
 

·
Registered
Joined
·
5 Posts
simlar issue with 02 tahoe

I have the same issue with my 2002 tahoe, where the air only blows from the defroster vents and the feet vents. does anyone know if this procedure will work on the 2003 tahoe as well?:confused::confused:
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
16 Posts
Great Write Up! Thank You, now I know what that sound is! I'm wondering if there could be something binding it elsewhere in the system, or is it that the plastic wheel just get brittle over time and looses teeth? For those that have replaced this part, what do you think?
 

·
Registered
2009
Joined
·
1,088 Posts
We took min apart to see what the issue is and they use gears with very fine teeth. On mine a couple of the teeth were missing. The other thing you can do is if you don't use the floor vents then just unplug the actuator and manually move it until the air is coming out the vents and then just leave it unplugged. This is what I will do next time as I never use the floor vents anyway.
 

·
Registered
Joined
·
5 Posts
Hello,

Great read.I know I am in the Trail Blazer forum, but I'm having same issue with my 2002 tahoe, do you know if this procedure will work with my tahoe? If not do you have any suggestions for me?

Thanks to all


I just replaced my mode actuator due to the dash vents not working; it wasn't too bad of a job; you just need to be patient and smart as you work.

First you need to find out what part number to order; just call the local GM dealer. you will need to give them your VIN; the P/N I used was 89018675 and I got it from www.parts4chevys.com for $46.33 which was alot cheaper than the dealership.

Remove lower dash covers. The actuator is located behind the middle portion of the dash; if you lay on the floor and look to the left you will see it.

Remove gray air duct as shown in pc #53; just pull it from it's endpoint; this way you can get to the actuator better.

There's 2 actuators; you want the one with the white gear coming out the side; it's the lower one in pic #52. You will need a 5.5mm socket to get the 2 screws out; be careful not to drop the screws; take your time.

Pic #46 shows the actuator; the two horizontal holes are where the screws mount; the other one close to the wire connection has a dowel that helps locate the actuator. You will need to adjust the white gear shown in pic #46
to be at the same location as the gear on the actuator you removed in order for it to go back in correctly. There are 3 marks on the back of the plastic housing (as seen in pic #46) and also slots in the metal part of the gear drive, the top slot is in the 1'oclock position in pic #46. Be sure your new actuator gear position matches the old and it will drop right in. I put the screws in the socket and then wrapped electrical tape around them so the screw wouldn't fall out during assembly. The whole thing took me 45 minutes.
The vents now work like a charm and I saved a bunch of coin!

You can doooo eeeet!
 

·
Registered
Joined
·
5 Posts
are the actuators inter-changeable?

Im ordering the part but im not sure if they are both the same.i can't find the part number for the 2002 tahoe.
 

·
Registered
Joined
·
16 Posts
uh curious...

Now i'm guessing maybe actuator causing this...No matter which mode i put my 2002 ENVOY SLT in (floor, defrost, defroster/ floor...) I ALWAYS get air coming out the dash vents. The Dash vents do NOT want to close unless i manually close the vent shade things. Do i need to replace this actuator or should i just replace the climate control assembly? Thank you.:confused:
 

·
Registered
Joined
·
5 Posts
Now i'm guessing maybe actuator causing this...No matter which mode i put my 2002 ENVOY SLT in (floor, defrost, defroster/ floor...) I ALWAYS get air coming out the dash vents. The Dash vents do NOT want to close unless i manually close the vent shade things. Do i need to replace this actuator or should i just replace the climate control assembly? Thank you.:confused:

Nycjinbx,

Im having the same issue with my 02 tahoe. I thought it was the climate control assembly as well, so I replaced it for about $100 bucks. It didnt work for me. Im thinking its the actuator. Im having a hard time locating it on my truck. Im going to the dealer tomarrow to get the part & should have it installed by end of the week. ill let you know my results
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
220 Posts
Mine clicks wen u turn the a/c on.... Ok now wen it doesn't click the a/c does not blow out of the driver side vent or the passanger side vent.... I was told it was the a/c blower motor is this correct or is it the actuator
 

·
Registered
2009
Joined
·
1,088 Posts
Mine clicks wen u turn the a/c on.... Ok now wen it doesn't click the a/c does not blow out of the driver side vent or the passanger side vent.... I was told it was the a/c blower motor is this correct or is it the actuator
It is the mode door actuator. Do a search and you will find a how-to plus you will see the threads that I have started on this. The mode door actuator on the 2002 is tricky because the shaft is pressed onto the actuator itself and according to GM requires a special tool. We were able to do it without the special tool and I explain how in that thread.

Here you go. I found it for you.

http://forums.trailvoy.com/showthread.php?t=45175&highlight=actuator
 

·
Registered
Joined
·
2 Posts
AC/Heat issue on 03 Envoy SLT

Okay, i have been reading several threads concerning this and I wanted to make sure I have total understanding of what to do or look for. Again, i have an 03 Envoy SLT. The AC blows fine out of the front driver side vents. The passenger and rear vents blow extremely hot air once the engine heats up. I do notice that I am hearing a clicking noise when I start the truck up that
lasts for a few seconds. The hot air also blows out from the floor vents. Is this the Mode Door Actuator that is causing my problem?
 
21 - 40 of 704 Posts
Top