Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 20 of 704 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
I just replaced my mode actuator due to the dash vents not working; it wasn't too bad of a job; you just need to be patient and smart as you work.

First you need to find out what part number to order; just call the local GM dealer. you will need to give them your VIN; the P/N I used was 89018675 and I got it from www.parts4chevys.com for $46.33 which was alot cheaper than the dealership.

Remove lower dash covers. The actuator is located behind the middle portion of the dash; if you lay on the floor and look to the left you will see it.

Remove gray air duct as shown in pc #53; just pull it from it's endpoint; this way you can get to the actuator better.

There's 2 actuators; you want the one with the white gear coming out the side; it's the lower one in pic #52. You will need a 5.5mm socket to get the 2 screws out; be careful not to drop the screws; take your time.

Pic #46 shows the actuator; the two horizontal holes are where the screws mount; the other one close to the wire connection has a dowel that helps locate the actuator. You will need to adjust the white gear shown in pic #46
to be at the same location as the gear on the actuator you removed in order for it to go back in correctly. There are 3 marks on the back of the plastic housing (as seen in pic #46) and also slots in the metal part of the gear drive, the top slot is in the 1'oclock position in pic #46. Be sure your new actuator gear position matches the old and it will drop right in. I put the screws in the socket and then wrapped electrical tape around them so the screw wouldn't fall out during assembly. The whole thing took me 45 minutes.
The vents now work like a charm and I saved a bunch of coin!

You can doooo eeeet!
 

Attachments

·
Registered
Joined
·
127 Posts
03Huggy, what prompted you to replace the Actuator? Currently my wifes '02 Envoy makes a clicking sound when you changes modes, like from the upper vents to the lower vents, etc. The air still comes out, but it makes the clicking noise like it is binding as it is changing positions. I didn't know if this is what you were experiencing or not?
Thanks
 

·
Registered
Joined
·
232 Posts
03Huggy, what prompted you to replace the Actuator? Currently my wifes '02 Envoy makes a clicking sound when you changes modes, like from the upper vents to the lower vents, etc. The air still comes out, but it makes the clicking noise like it is binding as it is changing positions. I didn't know if this is what you were experiencing or not?
Thanks
Mine just stopped working but made the noise, it did not change from Floor!
 

·
Registered
Joined
·
55 Posts
Lay on floor and look to left ---- From Driver or passenger side?
All the work is done from the drivers side.

03Huggy, what prompted you to replace the Actuator? Currently my wifes '02 Envoy makes a clicking sound when you changes modes, like from the upper vents to the lower vents, etc. The air still comes out, but it makes the clicking noise like it is binding as it is changing positions. I didn't know if this is what you were experiencing or not?
Thanks
Read my initial post again; it was due to the dash vents not working. The actuator door allows air to go to the dash vents and floor vents.
 

·
Registered
Joined
·
814 Posts

·
Registered
Joined
·
190 Posts
Got mine fixed today

I had 2 AC problems in 2 weeks. Thanks to TV folks got both of them fixed. I fixed the actuator this morning. I ordered the part from Rock Auto Parts online. 47.00 total price delivered to Charlotte NC. AC works great now, it was 94* today..:):thumbsup:
 

·
Registered
Joined
·
7 Posts
2002 TB HVAC Mode Door Actuator Replacement

I'm new posting here but have found this forum extremely helpful in researching both my 2002 trailblazer and a 2004 Envoy. Thanks to everyone who participates here.

I have researched this problem on the 2002 TB here, purchased the part and started taking things apart today to check out the real estate available for the repair. The only major obstacle I see is clearance to remove the lower screw holding the actuator in place. There is a metal brace supporting the steering column and there isn't enough space between the brace and the actuator to get the ratchet and socket into position. Has anyone experienced this problem in replacing these, and if so, how did you get around it without removing the brace?

Thanks again for a great forum!
 

·
Registered
Joined
·
190 Posts
The only major obstacle I see is clearance to remove the lower screw holding the actuator in place. There is a metal brace supporting the steering column and there isn't enough space between the brace and the actuator to get the ratchet and socket into position. Has anyone experienced this problem in replacing these, and if so, how did you get around it without removing the brace?

Thanks again for a great forum!


I had a "shorty" 1/4" nut driver. Put the socket on the end of it and it went up there no problem. Also had a 1/4" short ratchet that helped too. Don't forget when replacing the screws. Wrap some tape on the screw and socket. Works every time....

Also fill out your ID page so we know what you drive
 

·
Registered
Joined
·
154 Posts
I've changed the accuator once already on my "02 TB and gotta say the next day the "ticking" or "clicking" sound came right back very soft & low like... now 3 weeks later it "ticks" or "clicks" faster and louder. I'm kind'a hopnig someone might be helpfully with another though on fixing it or possible thinking it might be something else.... any help?
 

·
Registered
Joined
·
7 Posts
REmoving Panel at bottom of steering column

Is there any trick to removing the panel underneath the steering column to access the actuator. I removed all the screws, but the panel would not come out. Are there any "ears" that interlock with the trim pieces on either side of it?

I didn't want to pry on anything until I understood better how to remove it.

TIA for the help.
 

·
Registered
Joined
·
19 Posts
hi, great forum, thanks for all the great info. i hope this thread is the answer to my problem and i hope others can give me ideas.

2003 sle envoy. i recently (well last few months ) am only able to have A/C or heat come out of the front vents on the 3rd setting on the nob. A/C and heat works but only blows out strong on 4th and 5th setting and NOW today only on the 5th setting. before i had the battery die and had throttle problems and was able to fix it with a good cleaning of it...thanks to the forum. do you think its the " mode door actuator " that needs to be replaced? i too have had the clicking sound but strange as it might be only time i hear it is during the winter months. thanks for any help and great forum with great info.
 
1 - 20 of 704 Posts
Top