Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2005 Chevy Trailblazer LS, my key fob won't unlock the door's and for some reason my hatch back won't lock when I lock it manually, also my back wiper stopped working, all my dome light's stay on and when I turn the key off, the radio goes off and the time goes away, it didn't use to do that before! I changed the key fob battery, but it didn't help!
So what could be causing all that to happen at one time?
 

·
Registered
2003 Chevy Trailblazer LT
Joined
·
575 Posts
Howdy from Pennsylvania ! Welcome to the forum. My key fob hasnt worked in over 7 years and havent botherd to try and fix I just use the key. I took my rear wiper off a few years ago as I never used it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Howdy from Pennsylvania ! Welcome to the forum. My key fob hasnt worked in over 7 years and havent botherd to try and fix I just use the key. I took my rear wiper off a few years ago as I never used it.
My key fob has always worked until last Monday, it is a little bothersome, because for some reason it has caused other thing's to not work now! And I use my back wiper often, especially when it rains! I also like to lock my whole car up! But that's just how I am.
 

·
Registered
Joined
·
36 Posts
it’s probably either your lift gate control module (its located in the rear hatch and controls all your key fobs and everything) OR the wires going to the lift gate are damaged in some way (if you open the gate and look up top there is a rubberized tube with all the wiring passing thru it, thats a likely site because the gate crushes the wiring over time) both of these issues are somewhat common

i had this same problem back when i first got my tb several years ago and mine ended up being the lift gate literally severed all the wires going thru that rubber and i had the splice them all back together fixed my fob issue rear wiper issue all that it’s been fine ever since
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
it’s probably either your lift gate control module (its located in the rear hatch and controls all your key fobs and everything) OR the wires going to the lift gate are damaged in some way (if you open the gate and look up top there is a rubberized tube with all the wiring passing thru it, thats a likely site because the gate crushes the wiring over time) both of these issues are somewhat common

i had this same problem back when i first got my tb several years ago and mine ended up being the lift gate literally severed all the wires going thru that rubber and i had the splice them all back together fixed my fob issue rear wiper issue all that it’s been fine ever since
Thank you! At least you gave me a start of what the problem could be! I will have it checked out! I am disabled and it is hard for me to climb or do much with my hands! So I appreciate your help! Thanks again!
 

·
Registered
Joined
·
19 Posts
I also had the same issue. It was a broken wire in the hinge area where the wire pass through from the tailgate to the body. I spliced in a new wire 30,000 miles ago and no problems since.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
52 Posts
Howdy from Pennsylvania ! Welcome to the forum. My key fob hasnt worked in over 7 years and havent botherd to try and fix I just use the key. I took my rear wiper off a few years ago as I never used it.
Cam, I'm not sure if you give a shot, but I have an '03 LS. The key fob # is GM15008008 & 9 fob 1 and fob 2. Found them on google for 8 bucks a pc.

If you don't care, fine. just thought I'd throw it at ya. Ray PS, Battery is disc 2032.
 

·
Registered
2003 chevy trailblazer_ls
Joined
·
52 Posts
I have a 2005 Chevy Trailblazer LS, my key fob won't unlock the door's and for some reason my hatch back won't lock when I lock it manually, also my back wiper stopped working, all my dome light's stay on and when I turn the key off, the radio goes off and the time goes away, it didn't use to do that before! I changed the key fob battery, but it didn't help!
So what could be causing all that to happen at one time?
please go to the sign in page and edit to put in the info you just described so that the pros don't have to search. Thanks, Ray
 
1 - 16 of 16 Posts
Top