Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
621 - 640 of 676 Posts

·
Registered
2005 chevy trailblazer_ls
Joined
·
2 Posts
I should have found this thread last week when I changed spark plugs. Could have save time.
:) Thanks for the How-To

Cheers!
 

·
Registered
2005 gmc envoy_slt_xuv
Joined
·
17 Posts
Great instructions! I have been having rough idling when the vehicle is cold and I hope this fixes everything up. Didn't take much time at all and my TB was filthy. I guess I'll know tomorrow if this was the problem or not. :)
 

·
Registered
2005 gmc envoy_slt_xuv
Joined
·
17 Posts
Great instructions! I have been having rough idling when the vehicle is cold and I hope this fixes everything up. Didn't take much time at all and my TB was filthy. I guess I'll know tomorrow if this was the problem or not. :)
Well, I guess it wasn't going to be as easy as just cleaning the throttle body. On to other possibilities. :)
 

·
Registered
2005 gmc envoy_sle_xl
Joined
·
3 Posts
I have a 05 Envoy that I bought a month ago for my daughter with 184,000 miles. Runs great and real clean. So the battery starts to die this week so I pull it out yesterday and put in a new one, everyone knows where this is going. You got it it now runs like crap

So I find this topic today while watching my son play basketball. I pick up a can of TB cleaner on the way home and clean the TB. Runs better now, but still has a little. It of stutter and the flassing service engine soon comes and goes?

Any guesses, the TB was real dirty worse then any photo on here, clean now though. Will it just take some driving for the computer to reconfigure?

Thanks
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
5 Posts
Just in time.

I will soon be changing the spark plugs on my '06 TB. I will now clean the throttle at the same time while I have everything apart. Thank you for the info in this thread.
 

·
Registered
2006 chevy trailblazer_ls_ext
Joined
·
21 Posts
Cleaning Throttle Body....



I was wondering could you just clean the throttle Body without removing it, just by spraying in it and using a tooth brush to scrub it out... Also I have heard that you could use something like carburetor cleaner to clean it... Is this true or because it isn't meant for the Throttle Body would you not recommend it???

Thanks KYblazer06:thx
 

·
Registered
2006 saab 9_7x
Joined
·
450 Posts
The back side of the throttle body is where most of the grunge is. Try it your way first and then take it off. You will see why. Don't forget to disconnect the battery or pull the fuses for the PCM, for at least 30 minutes. Use what is recommended for the job, usually labelled Throttle Body Cleaner. There are lots of how tos on YouTube about this.
 

·
Registered
2004 gmc envoy_slt
Joined
·
1 Posts
Cleaning a throttle body

Hello:
Do you have to reset the IAC valve after cleaning the throttle body...2004 Envoy 6 cylinder?
 

·
Registered
2007 chevy trailblazer_ltz
Joined
·
9 Posts
What a great forum & knowledgeable group!

Thanks for the excellent post + half million comments!

Going to do mine over the weekend. 107,000 km's.
Doing 5,000 km's a month so can't but help!


:)
 

·
Registered
2003 chevy trailblazer_ltz
Joined
·
20 Posts
Idles fast after cleaning?

I had a service engine light on and cleaned the throtle body as well as aif flow sensor and installed new air filter . Light went out but idles fast 1100 to 1400 up and down. Getting ready to take it for a drive now.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
3 Posts
Had 2 TB's and this one was a peach till I tried to tow my bike back from Georgia, oil gauge would drop to 0 and would come back if I stopped and turned it off and back on took it off cruise and slowed to 55-60 and it stopped .... had happened 2 times since but no noise and it goes back to a little above 40 .... will it kicked a p0496 and p0014 code .... put Seafoam in the oil and down the vacuum tube to purge solenoid .... p0014 went away, but it started stalling and what I thought was a miss on accel and some times a cruise .... changed purge solenoid as it kept kicking that code .... you could blow threw the old one so I was told that it was bad ... stalling got real bad and had to work accelerator and brake .... saw this thread and cleaned tb with cleaner and soft brushes and cloth... better but still stutters on take of and sputters at cruise .... no codes after the purge solenoid replace .... this can make a grown man cry .... how long for puter relearn ... ? ... any more suggestions ???
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
3 Posts
Changed plugs and cleaned coils .... stalling and missing gone .... got real bad and never set a code .... oil gauge will still dip to O and back up ... will clean it and the port and do and oil change .... put in Seafoam last week ... things are looking up !!
 

·
Registered
Joined
·
1 Posts
when to do this??

when are you supposed to do this? Just when your truck is running rough or do you think this would be a fix also if you had the dashlight on (engine w arrow) and have have no acceleration whats so ever, according to the computer its the throttle body censor but in my case do you think that doing this clean would fix mine or is mine past the cleaning phase? I was going to order the part tomorrow but i just came across this so tomorrow I will take it off first and see what it looks like in there I guess.
 

·
Registered
2002 chevy trailblazer_ls
Joined
·
12 Posts
OK--just finished mine. I didn't pull off the air cleaner or flex hose. My car has 159XXX miles, but the throttle body seemed pretty clean, like someone recently did it. Still, there were deposits right around the pivot, and where the butterfly closed next to the pivot. After cleaning, my check engine light went out, and my car runs and idles much more smoothly. :thumbsup:
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
1 Posts
I just cleaned mine. It was filthy but cleaned it best I could. Before this, my trailblazer had the check engine light on and would power off when the a/c was on. The a/c would also only work on high. I was testing and the check engine was off and the truck doesn't power off anymore but the a/c won't work at all.
Test drove the car and it's running much smoother.
 

·
Registered
2003 gmc envoy_slt
Joined
·
56 Posts
cleaned throttle body

had the classic problem of rough idle and occasional stalling when at low idle (at stoplights) with the a/c on. rpm would dip below 600, and the engine would stumble and die. i could drive without the a/c, and it would keep running, but the idle still wasn't quite right (not smooth), and you could feel power loss and hesitation during regular driving. it has been a gradual decrease in performance, but today was the worst, since the engine would actually die in traffic when coming to a stop.

fearing the worst, i had a new set of plugs and camshaft timing solenoid ready in install.

however, i started with only cleaning the throttle body with a couple cans of carb/throttle body spray. the backside was relatively black and brown with carbon and varnish stains. wiping it clean with a rag and blasting it with cleaner removed 95% of the staining.

decided to test drive after the cleaning, and what do you know, it fixed the idle roughness/hesitation/dying, even with the a/c on. probably the best $8 i ever spent.

i'm returning the solenoid and plugs tomorrow.
 
621 - 640 of 676 Posts
Top