Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 7 of 7 Posts

·
Registered
2004 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter · #1 ·
WHATS UP EVERYONE I HAVE NOTICED MY T BLAZER HAS FELT SLUGGISH THE PAST 3 WEEKS IM WONDERING IF IT MY BE ONE OF THE SPARK PLUG BOOTS (COIL PACKS) IS THEIR A WAY THAT WE CAN TEST THEM OR CHECK THEM? AND IF ITS NOT THAT THEN WOULD COULD BE THE PROBLEM? oH BY THE WAY I CHANGED THE OIL ON IT AND IT STILL FEELS THAT WAY I KEEP UP WITH ITS MAINTANANCE NEXT ITS THE BRAKE PADS
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
Bad coils/boots will light the Check Engine Light to come on.

If your CEL is not lite, the coils are ok.

Check the air filter,

air tire pressure

and most probable, a dirty gas line filter.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Misfires almost always turn on the SES light and throw a code to tell you which one is misfiring (if it knows). General misfiring still lights up the SES lamp.

How many miles?

The sorts of things that don't throw codes are injectors (clean them with Seafoam or similar product), intake restrictions (air filter, etc.) and exhaust restictions (bent pipes, clogged cat.)

Not that it's a cause of sluggishness unless allowed to go too far, but have you ever cleaned the throttle body? Many folks need to do it every 30K miles.

http://forums.trailvoy.com/articles.php?do=viewarticle&artid=91

Oooo, boy scout Ray beat me this time. Carry on - I gotta go work on the Roadiemobile anyway.....
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter · #4 ·
It has 76k miles i cleaned the trhotle body about 2 weeks ago i went on roadies link on how to do it (thanks it worked) it was really dirty, so i cleaned it and it was running smooth and verry light so ill check the air filter it has a k&n filter if i took of the housing that covers it would it make a diference?
 

·
Banned
2003 gmc envoy_slt
Joined
·
7,190 Posts
It has 76k miles i cleaned the trhotle body about 2 weeks ago i went on roadies link on how to do it (thanks it worked) it was really dirty, so i cleaned it and it was running smooth and verry light so ill check the air filter it has a k&n filter if i took of the housing that covers it would it make a diference?
Not unless the tube that allows air in is plugged with a bird.:D An if you leave the cover off, you will be sucking in hot engine bay air.
 
1 - 7 of 7 Posts
Top