Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
4 Posts
Discussion Starter #1
First time poster! Great forum, already helped me fix a bunch of issues I've had with this 03 ext, 170k.
The problem: When coasting down steep grades in the Colorado Rockies the engine RPMs drop ~1500 and starts producing a really bad sound. I'll try to describe it: like change rattling around in a coffee can, a skateboard with bad bearings, gusting wind with a window cracked. Sound bit here: https://drive.google.com/open?id=1X__HMNZIHJ85YcWCak9MI7uQw6Ruzgn9

The noise stops immediately when any throttle is applied and the engine kind of thunks back into gear and everything sounds normal until the next downhill coast. I tried switching to neutral when this sound was occurring but it didn't have any effect, seemed like the truck was already in neutral. Tried switching to "auto" 4x4 and a horrible winding grinding sound started until slowing to a complete stop.

Know issues with the truck:
1. The 4hi and 4lo don't work. 4auto works. All the lights on the switch work 95% of the time, occasionally it will blink and nothing will light up. This is remedied by going into neutral and clicking from auto to 2hi/ 2hi to auto.

2.Fan clutch intermittently not working. Had a code for high fan speed a few times but usually turns off by itself.

Thanks for any input! This car is my source of income (uber driver), so I really appreciate any help.
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
4 Posts
Discussion Starter #2 (Edited)
Just a little sound bit description I forgot to add. The high pitch squeaking audible in the beginning is just my tape cassette adapter. I'm gaining speed as the sound increases and in the last second of the clip I press the throttle.
 
1 - 4 of 4 Posts
Top