Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
1 Posts
Discussion Starter · #1 ·
hello,
i wasn't sure where to put this because i am not sure what is wrong. i was driving on the highway yesterday with my 2006 trailblazer 4.2 6cy 4x4. when i lost power in the acceleration. the rpm's were spiked and the engine was moving, but the car was not accelerating, it was idling along at about 10mph like it was stuck in a gear. i went to go pull over and the brake was EXTREMELY touchy. normally the brakes are a bit spongy so you can gauge your stop, the barely tapped the brake and the whole car just stopped dead in its tracks. the traction control light and stabili-trac light came on. when i pulled over and looked back and had smoke coming from what looked like my rear passenger side, not the engine. i turned it off and called for a tow truck to take to the garage to get fixed. this morning they call and tell me there are no lights on and it's running fine, if they can't duplicate the problem there is nothing they can fix. well this has happened to me twice now, i don't feel comfortable driving the car, something IS wrong. clogged catalytic convertor, stabili-trac system stuck, transmission slipped, i mean they have to check there right? what does it sound like to you? any ideas?:confused:
 

·
Registered
2009 chevy trailblazer_lt
Joined
·
3 Posts
You may have two issues, I would check the rear brakes as it sounds like you had one of them hang up, also the wheel sensors may be starting to go. I have the same issue with my 2006 Tahoe (less the smoke and touchy brakes)
 

·
Registered
2009 chevy
Joined
·
263 Posts
Alauck, I’ll be sending you a PM for more details.

Thanks,
Laura
GM Customer Service
 
1 - 4 of 4 Posts
Top