Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
19 Posts
Discussion Starter #1
Ordered VVME HID with the relay. I have already installed Tblazed DRL Killer and it worked with my halogen lights. My HID work when I bypass the relay and just plug the factory into the ballasts (there is a 10 inch extension wire that is black/blue that VVME has attached to the bulb wires). So far my HID work without relay but I would like them to use the relay. There is only one female connector that is on the driver side. I know the two male connectors from the relay go into the ballasts. What am I doing wrong? Is it bad to continue running my HID without a relay?
 

·
Banned
2007 chevy trailblazer_ss_1ss
Joined
·
2,006 Posts
Since you installed a DRL killer your ballasts should be fine.. but since you have the relay harness you might as well use it to get maximum benefits and piece of mind.. the relay serves 2 purposes.. it protects your factory headlight wire harness' since they are so small and are suseptable to being burnt up, and the relay pulls the full 12V power from your battery that's needed to power your ballasts...

To use the relay simply power it from your positive terminal on your battery and ground it to a good ground, either your battery or I used my fender right next to the battery.. then the 2 wires coming from the relay plug into each of the ballasts and then finally only using one of your stock headlight wire harness (osince the relay only needs one signal to activate), plug the one into the relay harness, then obviously the other 2 wires coming off each ballast goes to the HID bulb and your golden..
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
19 Posts
Discussion Starter #5
I have done all of that and I am getting no noise from the ballasts like I used to when they were plugged in without the relay. I know I have all the connections right. Any other ideas as to what I could have done wrong. They won't even flicker with the relay yet work perfectly fine without it. :confused::confused::confused:
 

·
Banned
2005 chevy
Joined
·
6,469 Posts
I have done all of that and I am getting no noise from the ballasts like I used to when they were plugged in without the relay. I know I have all the connections right. Any other ideas as to what I could have done wrong. They won't even flicker with the relay yet work perfectly fine without it. :confused::confused::confused:
Aha!!! Take the 2 connectors from the relay that go into the ballasts, and flip them over. See if that does it.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
19 Posts
Discussion Starter #7
:bonk: Got it! They look awesome and its great to be safe using a relay and a DRL killer. Who said using double protection was bad... :thx
 
1 - 7 of 7 Posts
Top