Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
Hi. owner of an 02 trailblazer ls 102k. Begging for some tech opinions. this one has me stumpped.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
Help please

2002 trailblazer ls 4.2l. Was driving fine until a few days ago. Out of nowhere it doesn't crank. Luckily at the shop. I now of the common ignition switch problem. Replaced that about 2 years ago right after I installed a remote starter. During that install I actually soldered the wires in. Scotchclips are great at first but not for long term. Voltages at ignition switch: Brown-accy and run, Red/W all four, Pink-run and start, Yellow-start, White-accy, run and start, Red-all four, Orange-accy and run. By the power distribution diagram orange should only have run, I think the diagram is incorrect because it powers up the HVAC system which should work in accy position. Anyway I blew 30 bucks and got a new switch. Same result. I don't have a TECH2 so I can't see the crank parameter on my SOLUS. Also cannot see the starter relay enable parameter. Backprobing at the pcm i get battery voltage ppl pin 31 while turning ignition to start. I have battery voltage at dk grn pin 29 in run and start. Same at yel/blk pin 48, run and start. Those are on connector 1. On connector 2 I have zero ohms at pin 65. No voltage drop from pin 65 to ground terminal of the battery either. If I manually ground pin 48 the car will crank and start but dies within a second and flashes the security light. Turning off the key resets this and no security light flash when attempting to crank again
I hate condemning pcms but I think it has all it needs to crank. I grabbed a pcm and bcm from an 02 envoy at the local yard. My assumption is that the passlock system works through the bcm. I swapped them in and the exact same result, however now the door locks unlock when I remove the key with the replacement bcm. they did not and still do not with the original if I swap back. My SOLUS reads the different vin number and only throws a bcm code for the solar sensor. I have manual HVAC. I'll assume the envoy had automatic.
Are there any other modules that store the vin that could be affecting the VTD system and not allowing the pcm to give the crank relay ground signal? I dont think I have the immobilizer system. Can't find info on where to look for the module if I do. One last thing, I replaced the pcm with a programmed reman about a year ago to solve a throttle control issue.
Also wanted to add that when I try to start with the remote starter I get the same results.
 

·
Registered
2002 chevy trailblazer_lt_ext
Joined
·
404 Posts
Hey, no problem. Just putting it out there. Already 2 people that came over after getting crickets here.
 
1 - 6 of 6 Posts
Top