Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 14 of 14 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
14 Posts
Discussion Starter · #1 ·
I have had this problem for a few months now. First, the rear passenger side speaker went out. Tested it and it broke. I left it out and the other speakers worked fine. Last week just the driver side speakers and the dash speaker would work. Every now and then the passenger side speaker would come back on. Now only the dash speakers work and those are only highs. I tried another radio and that is not the problem. Could it be the amp??? OR??? Can all 4 speaker have gone bad??

Please help.

2006 Chevy Trailblazer
 

·
Registered
2003 gmc envoy_slt_xl
Joined
·
3 Posts
Same sort of thing with mine

I have an 03 envoy, and all of a sudden, the only speakers that work are the dash on the passenger side, and the door on the passenger side. Will post a solution if I can figure it out in the next few days...
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
18 Posts
I'm having the same issue on my 03 trail... My passenger side speakers is the only side that works. Sometimes while i'm driving the drivers sides speakers kick on but cuts out shortly after that... Anyone have any suggestions what could cause that???:eek:
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
207 Posts
well i am having the same issue.. i read somwhere that water can leak in the doors if the seals go bad and fry the speakers. on mine both rears went out and the passenger door only plays highs.


04 tb non bose, non nav
 

·
International Chapter
2004 chevy trailblazer_ls
Joined
·
3,900 Posts
uhh, finally, i wanted to raise this a while ago, me and my LS fellaws all have this prob, some in front some n back, while our other friends with Boss dont, so i guess its only n the base model :rolleyes: any idea what we can do ? i dont really care for a new set cuz i dont listen that much, fixing it would be great :yes:
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
207 Posts
after lots of searching this seems to be very common in all trailblazers...the good thing is with the bose systems they have to trouble shoot alot more stuff. :dielaugh: we just put new speakers in and BAM same performance less price. plus i like messing with my vehicles alittle.

im going to pick some up tomorrow from best buy and see if that fixes it. ill let you guys know what i find. i read that one guy said if you blow a speaker it should still make noise.....so if mine still dont work im going to have to trace the wires and look for a short somwhere:duh: got my fingers crossed.

oh and for all those people wondering about some cheap good speakers these are the ones im going to pick up tomorrow ($110 for all 4). for anyone that has somthing bad to say ive had several compatition systems and i have lost enough of my hearing.
http://www.bestbuy.com/site/olspage.jsp?skuId=8698698&type=product&id=1199494465847
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
207 Posts
i bought and installed all 4 speakers (ls model) it sounds great considering i only spent $108 for all 4. after my experience i do beleive the factory speaker are junk and cut in and out.

when i went to bestbuy rear speakers didn't work and front right was highs only. when i got home i checked all of them and they all worked fine exept the left rear:crazy: WTF new speakers in hand i went ahead and replaced all of them. so as for everyones that are cutting in and out go ahead and spend the 100 bucks.

also here is a help full DIY on installing speakers. very easy it took me about 3 hours because it was hot outside.

http://forums.trailvoy.com/articles.php?do=viewarticle&artid=70
 

·
Registered
2003 trailblazer_lt
Joined
·
9,856 Posts
Every now and then the passenger side speaker would come back on.
Sometimes while i'm driving the drivers sides speakers kick on but cuts out shortly after that
sounds like a loose wire/ connection......I would start by turning the radio on, and wiggling the wiring in the affected door(s) jam(s)....it gets more involved from there

I have an 03 Envoy and both rear speakers aren't working.
did they both go out at once?

i read somwhere that water can leak in the doors if the seals go bad and fry the speakers.
yep happened to me

Non-bose factory stereos should only have the front door components, and just the dash grille with no tweeters...
this

i read that one guy said if you blow a speaker it should still make noise
correct

it's common for the word "blown" to be used when describing any speaker/ woofer fault.

My 03 TB Buyer's Guide says 6 premium speakers, I do believe my dash tweeters work.
cool

when i got home i checked all of them and they all worked fine exept the left rear:crazy:
I hate when that happens. Glad you like the new speakers:cool:
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top