Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2002 chevy trailblazer_ltz
Joined
·
2 Posts
Discussion Starter #1
I have 02 trailblazer LTZ 6 cyl 4wd.My battery was low on fluid,got a new one Yesterday.Got in the other day,it started shaking upon driving.It acted like something was stuck in the fuel line. Like it wasn't getting enough fuel. I got up to a certain speed it would kind of straighten out. My first thought,my son had someone mad at him and put something in my gas tank?Ran it almost out and put some fuel injector cleaner to the next tank.Still bad.Running rough.Been reading all the post's and thinking it may be the coil cap and plugs.went to the parts store and got it tested for codes which I learned about on here.Thank you!Here is what came up: PO132 Heated Oxygen sensor-bank 1 sensor 1 (H02S11) high voltage and PO440 VAP evaporative emission system small leak/no flow condition. They each have 4 things it could be. Don't know where to start. Any suggestions? Is this something my son and I can do ourselves with suggestions and diagrams?
 

·
Banned
2004 gmc envoy_sle_xl
Joined
·
1,239 Posts
The first thing I would have done is clean the throttle body. When the battery was changed, the computer was reset and it went back to factory presets. If the throttle body is dirty, the computer had previously learned and readjusted parameters to run the engine. Before anyone starts changing parts, try this. There are articles on the site to give you instructions.
 
1 - 2 of 2 Posts
Top