Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 6 of 6 Posts

·
Registered
2007 chevy trailblazer_ls
Joined
·
15 Posts
Discussion Starter #1
A couple of weeks ago I blew a fuse in the box under the hood that kept the engine from starting. This happened a couple of times but no one seemed to know what was causing the problem. I bought a box of fuses and did not pursue the problem because I was having other health related problems. Thursday night my wife took the 03 Trailblazer ES and when she came home she said that the dash lit up light a Christmas tree and started flashing. The TB kept running and she was happy to make it home.
This morning I went out to look at the car and when I first tried the key it struggled but started. Now it won't start. It's not acting like it did when it was blowing the fuse. That fuse is OK. I am hoping this is simple.
Could someone help me. I'm not having much like with the professional service I have been paying for.

Thanks a lot

Jeff :(
 

·
Banned
2005 chevy
Joined
·
6,469 Posts
I had the same problem a couple of weeks ago. I would be driving (either surface streets, or highway) and the dash would go nuts for a couple of seconds, and then quit. Truck wouldn't shut off, and I could keep driving until I got to my destination. Then after that, it would be completely dead. Thankfully I have one of those jumper boxes... Weird thing was, it wasn't a consistent problem.

I went to Autozone to have them load test my battery and alternator, and they said my battery was bad. The guy offered to put in the new one for me, so I let him, and we found the problem (or so he said) The positive battery post (one of those extended kinds that I bought from them about a month prior) wasn't fitting as tight and flush as he thought it should. When you tried to wiggle it, it wasn't rock solid. We ended up putting a large washer on the bolt between the battery and the terminal, and that seemed to do the trick.

Maybe you've got the same thing going on with yours?
 

·
Registered
2008 chevy trailblazer_lt
Joined
·
135 Posts
Check the ignition switch, when they go bad, they cause all sorts of weird/strange problems. They are pretty inexpensive and easy to fix. Do a search and you'll find many threads on the problem and detailed instructions on how to change it out. Also, tb are sensitive to weak batteries. If yours tested bad get a new one.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
2 Posts
That sounds somewhat that happened to mine. I have a 04 TB LT. The other night coming home from church the dash lights started going crazy. But the headlights and the light on the radio was working and not flashing. Never lost power. Came on home and it is still running fine. I have to go on a trip next mnt. What do I need to check out? Also so sorry for jumping in on your question.
 
1 - 6 of 6 Posts
Top