Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 8 of 8 Posts

·
Registered
2005 gmc envoy_sle_xl
Joined
·
3 Posts
Discussion Starter #1
Hi all,

I'm having issues with my car. My 05 envoy was having intermittent starting issues for 3 months. I read on here that it could be the starter relay. I replaced that. Thought that fixed it. No dice! It started acting up again last week and taking the relay out and re-installing it didn't work this time. seems all week my wife couldn't start the car in the cool mornings but when i get home from work it would start just fine. I can't troubleshoot a problem that i cant replicate! ( Hard for wife to understand that!) now it wont start at all, i replaced the ignition switch and still didn't fix it. with the key in the run position and i bridge the starter solenoid it will turn the engine over but will not start. So recapping, new starter relay, new ignition switch, and starter will crank with screwdriver, no security lights flashing, and lights and windows work fine. What is the deal?
 

·
Registered
2005 gmc envoy_sle_xl
Joined
·
3 Posts
Discussion Starter #2
update

I ended up changing out the main fuse box and that fixed it. but now its doing it again. any ideas? last 2 times its done it is when the car was warm so im thinking starter solenoid
 

·
Banned
2004 gmc envoy_sle_xl
Joined
·
1,239 Posts
For any of us to be able to diagnose your problem, you need to clarify what you mean by "will not start". Does the starter spin? If not, then it sounds like you need to do some electrical investigation, since it spins when you jump the solenoid.
 

·
Registered
2003
Joined
·
1 Posts
My mom's 02 Trailblazer LT L6 4.2, 165,000 miles;

Has the same issue, I was going to do more research before I go tossing $600 and $700 at it. What happens is the lights will come on, and everything, when she turns the key, nothing. No clicking, no dimming of the lights, nothing, just plain jane no starter spin or anything. We've *sort of* been able to bypass it sometimes by knocking the starter (the old mechanic trick) sometimes it works, sometimes it doesn't. I saw a guy said it could be a fuse box issue? IS this the main box in the truck, or under the hood?

Or is it just another starter issue? Just replace the starter and move on?

Any advice is appreciated.

Thanks,
Mike
 

·
Registered
2002 gmc envoy_sle
Joined
·
15 Posts
We've been having this problem for years (There's another thread up here I started). No one seems to have figured it out. Clearly it's a relatively common problem. Been through the obvious replacements: relays, switch, etc. All but the starter itself. It always *eventually* starts. Until today. So I ordered another starter. I'll report back how this turns out once we swap it out. I suspect the solenoid is bad.
 

·
Registered
2002 gmc envoy_sle
Joined
·
15 Posts
SO we put the new starter in today, and problem solved (so far). As most know, the problem is intermittent, so can't say for sure for a while. But I will post back one way or the other.

The solenoid was definitely toasted on the old starter.

Rockauto has a starter for $65 or so, FYI. Had it overnighted and still saved almost 50% over autostone.
 

·
Registered
2005 gmc envoy_sle_xl
Joined
·
3 Posts
Discussion Starter #8
ign problems

I finally troubleshot it down to my fuses i had the right amperage fuse in but it was the ones that light up when they blow they were slowly melting and eventually blew. i started slowing down my start sequence by turning key to on wait a few seconds then to start. instead of instantly going to start. been fine for a couple years now.
 
1 - 8 of 8 Posts
Top